EGT Sensor P0546 and smog?
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on EGT Sensor P0546 and smog? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey WRX friends! I know my EGT sensor is probably going. I have a CEL of P0546, and sometimes another ...

  1. #1
    Registered User
    Join Date
    Jun 2006
    Posts
    44

    EGT Sensor P0546 and smog?

    Hey WRX friends!

    I know my EGT sensor is probably going. I have a CEL of P0546, and sometimes another that says P0546 PD which from what I understands it means it has occurred more then once. I can clear the CEL, and im fine for a couple days, and it comes back on, same code. When I clear the CEL, and drive around for a day, ill check it when I get home and it reads 0 codes. Do you think it will pass smog since the OBD2 reader shows 0 codes?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,962
    I Support ClubWRX
    That depends on your location, and on whether the sensors all report "ready" or not.
    WRX Info Links, Courtesy TheJ
    Man is a brute.... If you're cruel to him, he respects and fears you. If you're kind to him, he plucks your eyes out. Alexis Zorbas
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User
    Join Date
    Jun 2006
    Posts
    44
    I have heard that if you disconnect the leads off of the battery and tap them together it will reset the position of the EGT sensor... I also could try the 2.2 Ohm resister mod, but I thought that was for the MAF sensor on the intake. Mine was dirty, cleaned it off with some carb cleaner and all was well.

  5. #4
    Resident meany-rator 06wrx4me's Avatar
    Join Date
    Jun 2006
    Location
    Nor Cal
    Posts
    11,487
    I Support ClubWRX
    Quote Originally Posted by My02WRXIsHot View Post
    but I thought that was for the MAF sensor on the intake. Mine was dirty, cleaned it off with some carb cleaner and all was well.
    I wouldn't use carb cleaner or brake cleaner on the MAF. Both are very corrosive and not plastic friendly. They make MAF cleaner
    2014 Ford Fiesta ST

    06 WRX, HAWKEYE # 001 <T-boned and sold>

    COILOVER TABLE
    TURBO TABLE

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •