99 impreza check engine light
+ Reply to Thread
Results 1 to 8 of 8

This is a discussion on 99 impreza check engine light within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; hi i'm new in here mu car has the check engine and i can;t drive at all the car stay ...

  1. #1
    Registered User
    Join Date
    Aug 2010
    Posts
    5

    99 impreza check engine light

    hi i'm new in here
    mu car has the check engine and i can;t drive at all the car stay in 800 rpm if i press the gas it go to 600rpm
    i take to check what wrong with it and it 5 code
    p0500 speed sensor front
    p1540 speed sensor back
    p1101 neutral switch
    p1121 neutral switch high input
    p0130 O2 sensor open circuit front

    well i don't thing all this is no working it may be something can affect all this
    but i need other people opinion
    my car is 99 subaru impreza sedan 2.2l automatic trans

    if any body can help
    thank you

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    How many miles are on the vehicle? How long has the CEL been illuminated before you pulled the codes? I'm thinking you may have a harness pinched or something, check all the connectors at the bell housing and make sure no pins have backed out or the connecter is not loose. Are you having any other problems with the car? What happens if the vehicle is in park and you try and bring the RPM's up to like 3k and hold it there, will it perform normally? Are they symptoms you are describing only happen when the vehicle is in gear?

  4. #3
    Registered User
    Join Date
    Aug 2010
    Posts
    5
    141890 miles
    the rpm stay 800 in park and in gear

    but if you press many times the gas pedal the rpm go up
    when go back down came back to 800 rpm

  5. #4
    Registered User
    Join Date
    Aug 2010
    Posts
    5
    car in parked one year
    i don't remenber how long was the cel
    the only thing i know is one day didn't more

  6. #5
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Quote Originally Posted by revolution View Post
    car in parked one year
    i don't remenber how long was the cel
    the only thing i know is one day didn't more

    Was there anything wrong with the vehicle when it was parked over a year ago? My bet is perhaps something chewed threw the wiring or something, If none of these problems where present a year ago when the vehicle was parked and now they all appeared at once...

  7. #6
    Registered User devik's Avatar
    Join Date
    Jun 2006
    Location
    PHX Metro
    Posts
    276
    Quote Originally Posted by EvoEatr View Post
    Was there anything wrong with the vehicle when it was parked over a year ago? My bet is perhaps something chewed threw the wiring or something, If none of these problems where present a year ago when the vehicle was parked and now they all appeared at once...
    Agreed, it sounds like something happened to it while it was parked, most likely an issue with wiring or the ECU. I can't imagine how these codes would all be thrown at the same time otherwise.
    2002 Silver Bugeye WRX - Bugeye Mafia #327
    "Stage 2" + STI TMIC

  8. #7
    Registered User
    Join Date
    Aug 2010
    Posts
    5
    the codes show before i park the car

  9. #8
    Registered User
    Join Date
    Aug 2010
    Posts
    5
    the only thing remember one the i start and the rpm stay 800 i don't know what happen

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •