2002 wrx alarm issues
Results 1 to 5 of 5

This is a discussion on 2002 wrx alarm issues within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; hello i recently just purchased a suby wrx its got some issues but anyways it has a viper alarm system ...

  1. #1
    Registered User
    Join Date
    Jul 2010
    Location
    Hookedonphonex
    Posts
    79

    Exclamation 2002 wrx alarm issues

    hello i recently just purchased a suby wrx its got some issues but anyways it has a viper alarm system hooked up to it. im trying to figure out if it has the original alarm and the viper. i cant find any good diagrams on the net. the car randomly trips out and sets the alarm off and wont start and so on... i dont like how the viper system has just been spliced into the wire harness and i would like to get it all back to stock. so im trying to figure out the best way to go forward with this... can i get a wire harness and somehow get the original going or do i need to take it to a dealership. the original alarm was replaced due to the remotes being lost i am told. and now the vipers remotes are gone. so i have 1 key for the car. this is just the begining of the wrx work to be done. any ideas on where to start ???

    anything helps thx

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Well, removing the alarm system is sure a good place to start. I have wiring diagrams for the 2002 WRX, but it should be fairly self explanitory when takings the module out. Remove the wiring and resolder and heat shrink the original wiring back together, make sure you're lining up same colored/striped wires and don't leave any of them unattached to a partner.

    If you'd like the wiring schematics let me know.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  4. #3
    Registered User
    Join Date
    Jul 2010
    Location
    Hookedonphonex
    Posts
    79
    alright ya i took out the module but the car wont start without it plugged in. it will run how ever with just 1 of 4 plugs hooked up (green) pretty sure its the ignition killer or whatever its called. but i plan on taking it out and tryin to get it back to stock. but i guess if i cant figure that out i may replace the current one. going to be a long project for this car. thx for your help

  5. #4
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Yeah, that's how those interrupts work, until you get it all wires back together without the wiring for the alarm, you're going to have to have it plugged in.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  6. #5
    Registered User
    Join Date
    Jul 2010
    Location
    Hookedonphonex
    Posts
    79
    is the wiring schmatics you have from ken gilbert?

    im getting owned on this alarm issue. i removed the aftermarket alarm but the alarm light is still flashing and i bought a remote but the subaru guy could not get it to program. i am trying to locate the security module but cant even find it or maybe im staring right at it and dont even know. there are a couple plugs right behind the fuse box that are not plugged in i cannot for any open plugs.

    the car does run but i cant program or get the alarm to stop blinking. they really did a number on this im giong to mess with it a little longer. if i cannot get it i guess its going to the dealer... i wonder how much they are going to charge me???

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •