Turbo whistle normal?
Results 1 to 7 of 7

This is a discussion on Turbo whistle normal? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Im new to Subarus so this may be a dumb question. When Im driving and my turbo is at like ...

  1. #1
    Registered User mar1183's Avatar
    Join Date
    Jul 2010
    Location
    Delaware
    Posts
    61

    Turbo whistle normal?

    Im new to Subarus so this may be a dumb question. When Im driving and my turbo is at like -.05 half throttle it makes a whining like whistle noise but as soon as it gets in to boost it goes away. The car boost pretty good but it only goes up to like .07 or .08 boost in 1st gear then goes up to 1 when in second gear. Is this normal or do I have a problem?
    Oh some times in second gear it dosnt go all the way to 1 and if read correctly then 1 on my boost gauge from subaru should be 14 psi which is what they run stock correct? Thank you

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User mar1183's Avatar
    Join Date
    Jul 2010
    Location
    Delaware
    Posts
    61
    Oh and the car is completely bone stock no upgrades at all

  4. #3
    Registered User cjm1991's Avatar
    Join Date
    Jun 2009
    Location
    st louis
    Posts
    1,040
    Its probably just your turbo beginning to spool, but it could be a leak... doubt it though. 1 bar of boost should be 14.5 psi if im correct.
    Chris
    02 Camaro z28 T-Tops, m6 49k miles
    Bolt ons and tuned - 349rwhp/362rwtq
    02 Ws6 T-Top,m6 80k miles
    Bolt ons/Cam/tune - 436rwhp/424rwtq

  5. #4
    Registered User
    Join Date
    Apr 2008
    Location
    Sonoma
    Posts
    2
    I have an 03, and the factory boost gauge, and I get that whistle at 0 bar and it goes away when there is more boost. I think this is normal for our cars.

    PS I also have a KN drop in filter, this made this more noticable.

  6. #5
    Registered User mudferret's Avatar
    Join Date
    Aug 2009
    Location
    Canada/Ethiopia/Madagascar
    Posts
    1,979
    I have an '06, and I didn't notice any whistle until I went with an aftermarket downpipe, so I can't comment on whether it's normal for your particular year.

    Perfectly normal not to see peak boost in 1st gear.
    ...Rob.
    MMVI WRX - VF43 Airboy Tuned @ 3500'

  7. #6
    DUB
    DUB is offline
    Registered User DUB's Avatar
    Join Date
    Jul 2007
    Location
    SLT, CA
    Posts
    3,176
    The OE boost gauge measures in megapascals (Mpa), not bar. Boost from the factory is 13.5 psi or .093 Mpa. So, at full boost your needle should be just below .01 on the gauge.
    Boost is dependent on load, not gear or throttle position. To see your max boost do a wide open pull in 3rd or 4th gear.
    The whistling you are hearing is just the sound of the exhaust gases passing through and lightly spinning the turbine. It's normal. It gets really loud when you install a cat-less up pipe and delete the intake silencer (or install an after market intake). If you are achieving full boost, which sounds like you are based upon your observation of the gauge at .01, then you don't have a leak.

  8. #7
    Registered User mar1183's Avatar
    Join Date
    Jul 2010
    Location
    Delaware
    Posts
    61
    great help thank you so much guys!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •