Vibrations under power, sounds like a helicopter when clutched.
Results 1 to 2 of 2

This is a discussion on Vibrations under power, sounds like a helicopter when clutched. within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hello, glad to be a part of the site. I was planning to join anyway as I'm doing a Stage ...

  1. #1
    Registered User
    Join Date
    Jul 2010
    Posts
    1

    Vibrations under power, sounds like a helicopter when clutched.

    Hello, glad to be a part of the site. I was planning to join anyway as I'm doing a Stage 1 cpu upgrade to my bone stock Saab 9-2X Aero. But now that'll have to wait.

    Driving into work this morning my bone stock '05 Saab 9-2X (a WRX with Saab sheet metal) was running fine and smooth. I hit the on ramp like I normally do, drop to 4th gear at 50mph and power up to 65mph or so to merge. Then I shifted to 5th.

    The car starts shaking just a little bit, like I tossed a wheel weight on the front. Then it gets worse, really bouncing on both sides of the front end. As I'm driving it feels pretty shaky, and I noticed the vibration is worse under power. When I clutch in, there is a rhythmic thumping, but the vibration more or less goes away. When I'm on the brakes at pretty much any speed, there seems to be no problem.

    The car has 44k miles so I though it may be a ball or CV joint. I take the car to the shop, the mechanic says the suspension is fine. He drove it and noticed the same thing. Weird vibrations that are worse when cornering. He thinks it's the front diff, that something has blown up or gone out of alignment.

    Does this sound concievable? With such low miles, could I need a new tranny / front diff? I have an appointment at the local Subaru shop for a 2nd opinion, but any opinions I could get here would help. Thanks a lot!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    It sounds like a dif or tranny if they said there is nothing wrong with the suspention... did they check the tie rods and wheel bearings? Have you checked to see if there might be any tar or dirt pilled up in your wheel wells?
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •