rev limiter?
Page 1 of 2 12 LastLast
Results 1 to 15 of 27

This is a discussion on rev limiter? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; My 2002 wrx doesnt rev past 4200-4500 rpm when im sitting in neutral, is there a rev limiter set around ...

  1. #1
    Registered User Mr.Smith's Avatar
    Join Date
    Jul 2010
    Location
    Palos Hills
    Posts
    16

    rev limiter?

    My 2002 wrx doesnt rev past 4200-4500 rpm when im sitting in neutral, is there a rev limiter set around there or do i have a problem? thanks guys

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Master Baiter EJ257's Avatar
    Join Date
    Aug 2007
    Location
    On a stream bank somewhere
    Posts
    19,722
    I Support ClubWRX
    Why are you revving the car that high while in neutral?
    2005 WRX STi (Mods | Virtual Dyno)

    Resident Tuner @ WTF Tuning, LLC

    "Never trust anything that bleeds for a week and lives ..."

    UNYSOC

  4. #3
    Pro Manscaper Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    20,770
    Quote Originally Posted by EJ257 View Post
    Why are you revving the car that high while in neutral?


    I was gonna ask that same damn question...
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning
    "If I have 10 ice cubes and you have 11 giraffes, how many pancakes can fit on the roof? Purple, because aliens donít wear hats" -Ying

  5. #4
    Banned
    Join Date
    Dec 2003
    Location
    Dallas, TX / Sterling, VA
    Posts
    6,629
    I Support ClubWRX
    It's worth noting on NASIOC that this person said they are missing a bunch of sensors.....

  6. #5
    Registered User 2.0Rs's Avatar
    Join Date
    Jul 2007
    Location
    King of Prussia, Pa
    Posts
    1,168
    I love it when people as a basic general question and leave vital parts out. Really makes me wanna help them.

  7. #6
    Registered User falconflyer912's Avatar
    Join Date
    Dec 2007
    Location
    West Cheseter, PA and Mukilteo, WA
    Posts
    242
    Buy it used and still has launch control set up?

  8. #7
    Registered User cjm1991's Avatar
    Join Date
    Jun 2009
    Location
    st louis
    Posts
    1,040
    Quote Originally Posted by EJ257 View Post
    Why are you revving the car that high while in neutral?
    Exactly.
    Chris
    02 Camaro z28 T-Tops, m6 49k miles
    Bolt ons and tuned - 349rwhp/362rwtq
    02 Ws6 T-Top,m6 80k miles
    Bolt ons/Cam/tune - 436rwhp/424rwtq

  9. #8
    Registered User 2.0Rs's Avatar
    Join Date
    Jul 2007
    Location
    King of Prussia, Pa
    Posts
    1,168
    Guess it wasn't that important to him. lol

  10. #9
    Registered User Mr.Smith's Avatar
    Join Date
    Jul 2010
    Location
    Palos Hills
    Posts
    16
    sorry guys i have been away from my computer, i bought the car with the maf sensor missing, and about half the vaccum lines either disconnected or missing. So for the past few days i have been putting it back together. You guys have been a great deal of help but there are just things i dont know about WRX's, this is my first Subaru. The car mods on the car include a turbo back exhaust with no oxygen sensors hooked up and the coolant bypass mod. I do not know the previous history on the car because I got it from someone who got it from an auction.
    Last edited by Mr.Smith; 07-12-2010 at 06:01 PM.

  11. #10
    Registered User Mr.Smith's Avatar
    Join Date
    Jul 2010
    Location
    Palos Hills
    Posts
    16
    Quote Originally Posted by EJ257 View Post
    Why are you revving the car that high while in neutral?
    I honestly wanted to see what would happen, and like i said it cuts out at arounf 4200-4500 rpm and i dont know if that is how it is supposed to be?

  12. #11
    Registered User 2.0Rs's Avatar
    Join Date
    Jul 2007
    Location
    King of Prussia, Pa
    Posts
    1,168
    Quote Originally Posted by Mr.Smith View Post
    I honestly wanted to see what would happen, and like i said it cuts out at arounf 4200-4500 rpm and i dont know if that is how it is supposed to be?
    Well if that's where it is cutting out and you have no maf that is the reason. Your car is in limp mode. Get a maf (which isn't cheap brand new) and you can move on to your next problems.

  13. #12
    Registered User Mr.Smith's Avatar
    Join Date
    Jul 2010
    Location
    Palos Hills
    Posts
    16
    Quote Originally Posted by 2.0Rs View Post
    Well if that's where it is cutting out and you have no maf that is the reason. Your car is in limp mode. Get a maf (which isn't cheap brand new) and you can move on to your next problems.
    Ok cool, thats what i wanted to know. Someone on NASIOC said that my car might have launch control enabled, or even a tune, is there a way to tell?

  14. #13
    Admiral Ackbar the 1st mycologist's Avatar
    Join Date
    Oct 2005
    Location
    Late Devonian
    Posts
    13,133
    I Support ClubWRX
    Quote Originally Posted by Mr.Smith View Post
    Ok cool, thats what i wanted to know. Someone on NASIOC said that my car might have launch control enabled, or even a tune, is there a way to tell?
    If you can find someone local with a cable or purchase one and download the map from the ECU (not hard if you have access to the cable) we can look at it for you. Maybe post in your regional subforum here asking if anyone has an openport or tactrix cable or try a local forum. Or buy your own (great thing to have).
    Last edited by mycologist; 07-12-2010 at 06:57 PM.
    "From a little spark may burst a mighty flame." - Dante
    "The stitch is lost unless the thread is knotted." - Italian proverb

  15. #14
    Registered User 2.0Rs's Avatar
    Join Date
    Jul 2007
    Location
    King of Prussia, Pa
    Posts
    1,168
    Quote Originally Posted by Mr.Smith View Post
    Ok cool, thats what i wanted to know. Someone on NASIOC said that my car might have launch control enabled, or even a tune, is there a way to tell?
    Quote Originally Posted by mycologist View Post
    If you can find someone local with a cable or purchase one and download the map from the ECU (not hard if you have access to the cable) we can look at it for you. Maybe post in your regional subforum here asking if anyone has an openport or tactrix cable or try a local forum. Or buy your own (great thing to have).
    This^^^^

    But like I stated if you are positive you do not have a maf sensor you need one. When you unplug your maf or it blows your car goes into limp mode not allowing you to rev over a certain rpm and also your car will run crazy rich to prevent damage. If this is the case this is not a launch limiter. Get yourself a maf, hook it up, then try reving it. I would not bother even trying to figure out if a launch limiter is installed until you have the proper sensors in.

  16. #15
    Admiral Ackbar the 1st mycologist's Avatar
    Join Date
    Oct 2005
    Location
    Late Devonian
    Posts
    13,133
    I Support ClubWRX
    Yup.
    "From a little spark may burst a mighty flame." - Dante
    "The stitch is lost unless the thread is knotted." - Italian proverb

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •