Driving with P0172
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on Driving with P0172 within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So how dumb is it to drive around with P0172 System Too Rich (Bank 1)? I got the code after ...

  1. #1
    Registered User wo^tron's Avatar
    Join Date
    Jun 2010
    Location
    Naples, FL
    Posts
    188

    Driving with P0172

    So how dumb is it to drive around with P0172 System Too Rich (Bank 1)? I got the code after putting a new engine harness on, and I reckon I messed something up installing the harness unless the dealership gave me the wrong harness...

    <ADD>
    I've kind of been suspicious of it because the injector plugs were ass backwards, but everything else hooked up just fine, I went and had my friend solder and rotate them. The dealer said it was the (revised) harness for an 04 STi though.
    </ADD>

    I just wanted to know how safe it is to drive around to work and what not a day here and there with that code? I'm not planning a cross country trip or anything like that
    Put aside the everyday world and come with us
    Into the realm of imagination
    The middle ground between light and shadow

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Well, Personally I would rather have a P0172 (system rich) that a P0171 (system lean)..This is a difficult question to answer fore you dont know the exact problem with the vehicle. Personally if the vehicle sounds ok and doesnt show any signs of problems I would drive it ( no guarantees something couldnt go wrong though )...Do you have the ability to view fuel trims and ECU data? , What happens if you clear the code...does the CEL illuminate immediately again? How many miles are on the vehicle?

  4. #3
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,978
    I Support ClubWRX
    PO172 and PO171 are troubleshot much the same way. You're looking for a vacuum or boost leak, a fuel pressure regulator that's not connected well, or a metering problem. I'd park and fix it if possible.
    WRX Info Links, Courtesy TheJ
    Man is a brute.... If you're cruel to him, he respects and fears you. If you're kind to him, he plucks your eyes out. Alexis Zorbas
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  5. #4
    Registered User wo^tron's Avatar
    Join Date
    Jun 2010
    Location
    Naples, FL
    Posts
    188
    Yeah I've gone and cleared the code but at idle it will bog down and the CEL will come back. Driving it's fine. I only get a little bit of black smoke at idle when I rev it or it starts up real rich and has a hard time venting it also mists from time to time like when my upstream o2 sensor was going. I have a tactrix cable but it doesnt want to connect to romraider anymore
    (Keep in mind everything tune wise was perfect before I put the harness on)

    When I get a minute I'm going to go trouble shoot it. I read somewhere that system too rich causes the AFRs to drop around 35%. So I reckon I idle in the 9's since thats when its boggy. Like something is wrong with the intial startup, when i turn the car on it kinda sputters a bit until the RPMs build up and the fuel clears out. I think I just didn't put something together right or kinked a fuel line or something dumb like that.

    The car has around 57,000 miles on it with a 255lph walbro that probably has 20k on it. I don't know about the fuel filter though. I also have Power Enterprise 850cc injectors
    Last edited by wo^tron; 07-11-2010 at 01:04 AM.
    Put aside the everyday world and come with us
    Into the realm of imagination
    The middle ground between light and shadow

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •