Turbo or Wastegate?
Results 1 to 3 of 3

This is a discussion on Turbo or Wastegate? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Ok here ive got my 05wrx with fpevo3-16g turbo and all supporting mods. Everytime id get on it a little ...

  1. #1
    Registered User dyaboy96's Avatar
    Join Date
    Jan 2008
    Posts
    125

    Turbo or Wastegate?

    Ok here ive got my 05wrx with fpevo3-16g turbo and all supporting mods. Everytime id get on it a little it well only spool up to about 5 or 6 psi and my stock internal wastegate would make a loud noise but the car wouldnt move anywere{5-6psi}
    I was wondering if it was the turbo or the wastegate because i checked and i didnt have any leaks?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,847
    I Support ClubWRX
    The IWG should not be audible. You probably have either a preturbo exhaust leak or a boost leak.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  4. #3
    Registered User abhiwan's Avatar
    Join Date
    Oct 2005
    Location
    Staten Island, NY
    Posts
    2,179
    Quote Originally Posted by Donkey View Post
    The IWG should not be audible. You probably have either a preturbo exhaust leak or a boost leak.
    +1, check all piping between intake manifold down to the turbo. you're losing pressure somewhere.
    2012 VW GLI
    2012 Toyota Sienna LE AWD (thats right...swagger wagon)
    Hawk-Eye Alliance #011

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •