Help!! Battery light and E-Brake light on
Results 1 to 10 of 10

This is a discussion on Help!! Battery light and E-Brake light on within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I am hoping someone can help me. I recently purchased a 2002 WRX Wagon. It has 110k on it and ...

  1. #1
    Registered User
    Join Date
    Jun 2010
    Posts
    4

    Help!! Battery light and E-Brake light on

    I am hoping someone can help me. I recently purchased a 2002 WRX Wagon. It has 110k on it and runs great. About a week after I got it the E-Brake light and Battery light came on sporadically and now its not going away. I searched the other threads and found that the E-Brake light will come on if the fluid is low so I topped that off hoping it would help. No luck. The belts look like they are in good shape (no cracking or visable wear). I also read that it could be an electrical issue but the battery is new and I haven't noticed any loss of power, dimming of any lights at idle or any of the normal signs associated with the alternator going bad or a dying battery. The battery was replaced before I bought it so I don't think that is the problem. I'm new to the Subie scene and I apologize if this question has been answered in another thread. I did my due diligence and searched before posting a new thread but couldn't find anything. Hope you guys can help. Thank you.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Price is right's Avatar
    Join Date
    Jul 2009
    Location
    louisville ky
    Posts
    27
    Quote Originally Posted by rusky314 View Post
    I am hoping someone can help me. I recently purchased a 2002 WRX Wagon. It has 110k on it and runs great. About a week after I got it the E-Brake light and Battery light came on sporadically and now its not going away. I searched the other threads and found that the E-Brake light will come on if the fluid is low so I topped that off hoping it would help. No luck. The belts look like they are in good shape (no cracking or visable wear). I also read that it could be an electrical issue but the battery is new and I haven't noticed any loss of power, dimming of any lights at idle or any of the normal signs associated with the alternator going bad or a dying battery. The battery was replaced before I bought it so I don't think that is the problem. I'm new to the Subie scene and I apologize if this question has been answered in another thread. I did my due diligence and searched before posting a new thread but couldn't find anything. Hope you guys can help. Thank you.

    I am also slightly nubish, but i had a similar problem with the brake light periodicly comming on. about a week after it started happening, i changed my brake pads. havent had the light on since. i believe this is a subaru thing, as my moms tribeca did the same thing. new pads and it went out. as for the battery, my guess would be a short somewhere but i dont have any personal expirence with that. sorry if this doesent help.
    bugeye mafia #232
    World Rally Blue 2002 WRX Stage 2 290 awhp
    my mods

  4. #3
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,559
    I Support ClubWRX
    Check the charging system. It's either the battery, the alternator, or the connections between them.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  5. #4
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,086
    I Support ClubWRX
    Quote Originally Posted by SD_GR View Post
    Check the charging system. It's either the battery, the alternator, or the connections between them.
    +1 When the battery and brake light are on its the charging system.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  6. #5
    Registered User
    Join Date
    Jun 2010
    Posts
    4
    Quote Originally Posted by Donkey View Post
    +1 When the battery and brake light are on its the charging system.
    What am I looking for when I check it? It has a new battery and I haven't had any issues with dimming lights or difficulty starting it. I'm not seeing any of the normal signs of the alternator taking a crap on me...

  7. #6
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Quote Originally Posted by rusky314 View Post
    What am I looking for when I check it? It has a new battery and I haven't had any issues with dimming lights or difficulty starting it. I'm not seeing any of the normal signs of the alternator taking a crap on me...

    do an alternator output test, you could also check the diode pattern , as mentioned the e-brake warning light and the battery light are on the same circuit I believe, have seen this problem many times on all Subarus in general, 99% of the time its the alternator....

  8. #7
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,086
    I Support ClubWRX
    Quote Originally Posted by rusky314 View Post
    What am I looking for when I check it? It has a new battery and I haven't had any issues with dimming lights or difficulty starting it. I'm not seeing any of the normal signs of the alternator taking a crap on me...
    Test the voltage off the battery when the car is at idle. You should be seeing between 13.6-14.2 volts. If your seeing battery voltage (12-12.5volts) your alternator is shot.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  9. #8
    Registered User
    Join Date
    Oct 2009
    Location
    Milton
    Posts
    10

    E-brake and Battery light

    I'm getting a e-brake and emergency light issue as I accelerate? I've tested the voltage at the battery at idle and it seems fine @ 13-14Volts. I notice if I rev the engine it goes slightly over 17Volts. Is this normal? Do I have an issue with a regulator?

  10. #9
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,559
    I Support ClubWRX
    Quote Originally Posted by shankster26 View Post
    I'm getting a e-brake and emergency light issue as I accelerate? I've tested the voltage at the battery at idle and it seems fine @ 13-14Volts. I notice if I rev the engine it goes slightly over 17Volts.Is this normal?
    I don't think so.

    Do I have an issue with a regulator?
    I believe so.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  11. #10
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,086
    I Support ClubWRX
    You need a new alternator ASAP. You should not see over 15 volts.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •