Emissions problem???
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on Emissions problem??? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Yesterday on the way home from work, all of the sudden my check engine light comes on. My Si drive ...

  1. #1
    Registered User BuellSTI's Avatar
    Join Date
    May 2010
    Location
    Maple Valley
    Posts
    15

    Emissions problem???

    Yesterday on the way home from work, all of the sudden my check engine light comes on. My Si drive is stuck on sport mode blinking...my cruise light is blinking also. My traction control light is on as well. So check engine light and traction control light stay lit solidly. My sport and cruise light blink. Then it was off this morning until about twenty minutes into commute then all lights did same thing.???Dealer said it was emissions problem?? Any thoughts. Car just hit 21,000 miles. Has downpipe, intake, headers, catless exhaust, front mount, blowoff, cobb chipped and Surgeline tuned.
    Last edited by BuellSTI; 07-01-2010 at 05:56 PM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    When the CEL illuminates it disables certain systems which is why your traction control, cruise control, and SI drive lights where illuminated or stuck, Did the car run any differently? Did you recently refuel the vehicle? Next time the light comes on I would prob drive it right to a shop where they could at least pull the code, than you will have some direction to go...

  4. #3
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Only way to know is to actually get the code pulled, then we can tell you what the problem is.

    Like EvoEatr said, it's normal for all that stuff to come on and blink when the CEL is on. I'm kinda grateful I only have a cruise light that blinks at me when my CEL is on
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  5. #4
    Registered User BuellSTI's Avatar
    Join Date
    May 2010
    Location
    Maple Valley
    Posts
    15
    My car actually runs normal...have appointment tomorrow morning. I did actually fuel up recently too...with 94 octane. Only one place that actually has it around here so i decided while driving through to fill up. Usually use 92 as that's the norm around here. Ty for quick response.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •