Sort of clicking when first move forward
Results 1 to 9 of 9

This is a discussion on Sort of clicking when first move forward within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey guys I have a 2010 wrx only about 1300 km on her. Just wondering if this is a normal ...

  1. #1
    Registered User mrsailboats's Avatar
    Join Date
    May 2010
    Posts
    50

    Sort of clicking when first move forward

    Hey guys I have a 2010 wrx only about 1300 km on her. Just wondering if this is a normal thing that happens to everyones as it doesn't seem to major. When I first turn it on and drive, there is a sort of click that seems to come from near the front wheels. It only happens once and it drives perfectly fine. Maybe I'm paranoid but ya any thoughts?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User 2010obp's Avatar
    Join Date
    May 2010
    Location
    Modesto, CA
    Posts
    2
    Same thing here on my 2010. It's like a loud knock... has kind of a lower tone than a click. It's bizarre.

    I think I remember reading somewhere that it was normal, but I'm not sure and I can't find the link. I'm sure someone on here knows more than me about it, lol.

  4. #3
    Registered User
    Join Date
    Mar 2009
    Posts
    133
    I remember hearing that on my 08 for the first few thousand miles. It went away after a while.

    Probably just the joints and mounts in your car settling. Thats why its wise to take it easy until its broke in.

  5. #4
    Registered User
    Join Date
    Jun 2010
    Posts
    89
    750 miles on my 2010 and when you first put it in first after it sitting for an hour or so Click/Thud. I think its normal.

    Im not worried. That's what a warranty is for right?

  6. #5
    Registered User bjkeed21's Avatar
    Join Date
    May 2010
    Location
    JC/NB, NJ
    Posts
    53
    my 2010 has about 1400 miles on it, and its done the same thing under the same conditions all the time

    iv also read the same thing from numerous drivers of the same generation wrx, so i wouldnt be too worried
    2010 WRB WRX 5Door
    Stink-Eye Mob #29

  7. #6
    Registered User economatic's Avatar
    Join Date
    May 2009
    Location
    Portland, OR
    Posts
    840
    Could it be the ABS system initializing? All of the vehicles I have owned with ABS made distinctly different sounds when first moving forward but it was always the ABS system.

  8. #7
    Registered User armindk's Avatar
    Join Date
    Dec 2009
    Location
    louisville, ky
    Posts
    291
    Since you brought it up, our 2010 Toyota Camry makes the same noise. At the first start up after a left turn there is a loud click as well. Hmmm this is interesting. Might be the ABS like economatic said.

  9. #8
    Registered User mrsailboats's Avatar
    Join Date
    May 2010
    Posts
    50
    Great thought, I will check into this!

  10. #9
    UnBanned Sinister's Avatar
    Join Date
    Nov 2006
    Location
    Denver Metro Area
    Posts
    17,621
    I Support ClubWRX
    I've heard diff explanations from hill assist releasing, to abs initializing, etc. The general consensus is that it's normal.
    Kevin
    Moderator
    Sinister's Blowoff Valve FAQ
    WRX Gas Mileage FAQ
    Sinister's Progress Thread - 430whp 429wtq - Sold
    Firearms Enthusiasts Thread

    The Sheriff's Star at the bottom left corner rates a user's reputation.
    If you found a user's post to be helpful or quite the opposite, please make it known to them by clicking the Star!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •