need help asap
Results 1 to 5 of 5

This is a discussion on need help asap within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; so i got a 04 wrx with 103k on it hks bov hks turbo back exhaust k & n typhoon ...

  1. #1
    Registered User sawb_wrx's Avatar
    Join Date
    Jun 2010
    Posts
    4

    need help asap

    so i got a 04 wrx with 103k on it hks bov hks turbo back exhaust k & n typhoon intake and some down pipe and cobb stage 2 tune was on it when i bought it well need to get smogged so i put stock down pipe on and now my check engine if flickering on and off and my fuel door light is on and my boost gauge when idleing is reading -15 go up to -10 then back down to -15 any advice ?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    12,946
    I Support ClubWRX I Support ClubWRX
    Quote Originally Posted by sawb_wrx View Post
    so i got a 04 wrx with 103k on it hks bov hks turbo back exhaust k & n typhoon intake and some down pipe and cobb stage 2 tune was on it when i bought it well need to get smogged so i put stock down pipe on and now my check engine if flickering on and off and my fuel door light is on and my boost gauge when idleing is reading -15 go up to -10 then back down to -15 any advice ?
    did you reflash the stock tune?

    EDIT:
    There are a lot of possibilities. Hook up your Cobb AP, read the CEL, and post the CEL in this thread. But reflash the stock map first
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  4. #3
    Registered User RazzWRX's Avatar
    Join Date
    Jun 2010
    Location
    Frankfort KY
    Posts
    1

    need help!!

    OK i have a 2002 wrx, just new tranny but my car started fibrateing and i check the tranny and thats not it someone told me to check the coils on my cylinders and he said it could be the cylinders but where the heck are they and the plugs to... any help..

  5. #4
    Registered User erksplee's Avatar
    Join Date
    Sep 2009
    Location
    PA
    Posts
    124
    Quote Originally Posted by RazzWRX View Post
    OK i have a 2002 wrx, just new tranny but my car started fibrateing and i check the tranny and thats not it someone told me to check the coils on my cylinders and he said it could be the cylinders but where the heck are they and the plugs to... any help..
    Dude. Your Engrish is astounding!

  6. #5
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    12,946
    I Support ClubWRX I Support ClubWRX
    Quote Originally Posted by RazzWRX View Post
    OK i have a 2002 wrx, just new tranny but my car started fibrateing and i check the tranny and thats not it someone told me to check the coils on my cylinders and he said it could be the cylinders but where the heck are they and the plugs to... any help..
    Next time, create your own thread. You'll get more responses this way .

    To know the location of the spark plugs on a Subaru, you're going to have to have a basic understanding of the Boxer engine architecture. Unfortunately for us, the spark plugs are located underneath the coilpacks -- two on the drivers side under the washer fluid and two on the passenger side under the intake scoop. Please, for the sake of us all, run a quick search on "changing spark plugs."

    I really doubt that the coil packs are your problem... if you had a bad spark discharge, you'd throw a cylinder misfire CEL. If by "vibrating" you mean a rough idle, you might consider cleaning your MAF sensor (verrrry carefully). Who installed the tranny? you might want to check your driveline continuity if you're referring to vibration while driving.

    But then again, I really have little idea what I'm talking about

    Bump
    Last edited by zax; 06-22-2010 at 06:49 PM. Reason: crappy ass grammar
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •