burning rubber smell, light smoke
Results 1 to 4 of 4

This is a discussion on burning rubber smell, light smoke within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Ugh! Just got an engine with 64,000/new turbo/clutch kit for my 03 WRX. I've driven it 150 miles and now ...

  1. #1
    Registered User
    Join Date
    Dec 2009
    Posts
    11

    Unhappy burning rubber smell, light smoke

    Ugh!

    Just got an engine with 64,000/new turbo/clutch kit for my 03 WRX.

    I've driven it 150 miles and now there is a burnt rubber smell with light smoke coming from the turbo/downpipe area after I drive. It is not a lot of smoke, but the smell is gruesome. I've read many posts on here and now I am even more confused.

    Any ideas what this could be? I don't feel safe driving it like this. It just smells like wires touching something hot, but the smoke is almost like steam. All the coolant and oil levels are good. Belts are good. Please someone give me some divine knowledge. It is much appreciated. Thank you!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User apd973's Avatar
    Join Date
    May 2008
    Location
    new jersey
    Posts
    86
    wheres the smoke coming from? might be the head gasket. is it leaking any oil?
    bugeye !

    pm me if you need custom vinlys.

  4. #3
    Admiral Ackbar the 1st mycologist's Avatar
    Join Date
    Oct 2005
    Location
    Late Devonian
    Posts
    13,150
    I Support ClubWRX
    Is anything touching the DP? There is a rubber AC drain hose that comes through the firewall down there.
    "From a little spark may burst a mighty flame." - Dante
    "The stitch is lost unless the thread is knotted." - Italian proverb

  5. #4
    Registered User
    Join Date
    Dec 2009
    Posts
    11
    The smoke is coming from the turbo area under radiator fluid container. It is a very light smoke that looks like steam. It is not the head gaskets because Subaru replaced them a couple months back. I can only assume that when the mechanics put my engine together, they did not hook something up properly. I need to drive it back to where I live as I am stuck at my parents house in NJ. I hope that I can make it before harming something else.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •