A/C Question. I live in AZ!! Need adcvice
Results 1 to 4 of 4

This is a discussion on A/C Question. I live in AZ!! Need adcvice within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; My car's A/C blows cold and gets cool pretty fast, even on a hot day here in AZ. The only ...

  1. #1
    Registered User Mark_02WRX's Avatar
    Join Date
    Apr 2010
    Location
    Casa Grande, AZ
    Posts
    56

    A/C Question. I live in AZ!! Need adcvice

    My car's A/C blows cold and gets cool pretty fast, even on a hot day here in AZ. The only problem is sometimes (every few minutes) it'll warm up, it doesn't get hot but it'll just warm up a little bit.

    I'm guessing it just needs a recharge?? If it does do you guys have any experience or recommendations in recharging it with refrigerant bought from auto stores or is it best to get it done professionally at a shop??

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,551
    I Support ClubWRX
    Do not guess. Take it to a shop and have it checked. The symptoms you describe could be normal, or could be due to a number of things (and IMO a low charge isn't one of them). In any case, get someone to put gauges on the system and check your pressures.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User Mark_02WRX's Avatar
    Join Date
    Apr 2010
    Location
    Casa Grande, AZ
    Posts
    56
    Will do. Thank you sir!

  5. #4
    Registered User Mark_02WRX's Avatar
    Join Date
    Apr 2010
    Location
    Casa Grande, AZ
    Posts
    56
    Got it checked out today and it turns out the level of refrigerant in the system was low

    They completely drained it and added new refrigerant plus some kinda liquid that shows where leaks are under ultra violet light, I have to bring it back after 300mi of driving. Hopefully it doesn't have a leak!!

    Anyways, thanks again for the advice. That's one less thing less on my check list before I upgrade the turbo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •