Multiple Problems....Help Please
Results 1 to 11 of 11

This is a discussion on Multiple Problems....Help Please within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hi Guys (and Girls), This is my first post to the forum but I must say I am impressed with ...

  1. #1
    Registered User
    Join Date
    May 2010
    Posts
    2

    Multiple Problems....Help Please

    Hi Guys (and Girls),
    This is my first post to the forum but I must say I am impressed with how much information is available so it wont be my last.

    I own a 2002 WRX Wagon and I have had no problems with it over the last three years. However, this last week my car started giving me a ton of issues. Hopefully some of you might be able to help me.

    Last week my power steering went out. A few days later I noticed that my panels were acting really strange. The MPH gauge and RPM Gauge would go down to 0 and then shoot back up to their respective numbers, then my radio started turning off for a few seconds and then turn back on. Sure enough the next day my car wouldnt start. After a quick jump my car would get going again. The next day I jumped the car and When I started moving at a green light my car stopped responding to the gas pedal, the engine would fail to rev and it would clunk around. I turned the car off and pushed it to a curb on the side of the road.

    So in total, my battery is dead, gauges are faulty, gas pedal gives no response, and my power steering is out.

    Any ideas...

    Thank You All.

    -Dennis

    BTW: On my panel the E-Brake and Battery light were both on whenever I would drive my car. The E-Brake was down so I dont know what is causing this.
    Last edited by dholland; 05-10-2010 at 12:24 AM. Reason: Edited to add one more problem

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Admiral Ackbar mycologist's Avatar
    Join Date
    Oct 2005
    Location
    Late Devonian
    Posts
    12,731
    I Support ClubWRX
    Your belt is probably buggered hence it not turning the PS & alternator. Your battery dying could cause the rest of the symptoms except maybe the e-brake light.
    "From a little spark may burst a mighty flame." - Dante
    "The stitch is lost unless the thread is knotted." - Italian proverb

  4. #3
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,220
    I Support ClubWRX
    It'd cause the brake light too. A common symptom of a charging fault is both the brake and the battery lights coming on. The OP needs IMO to check the belts, pulleys, and tensioners, and if need be replace using authentic parts. I'm hoping there is little, if anything, else wrong with the car.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  5. #4
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,968
    I Support ClubWRX
    Yup. Just follow the maintenance guide in the owners manual. Belts should be checked often. The power steering and alt are on the same belt and the AC a seperate one.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  6. #5
    Registered User PREracing's Avatar
    Join Date
    Nov 2006
    Location
    GRESHAM, OR
    Posts
    159
    Quote Originally Posted by dholland View Post
    Hi Guys (and Girls),
    This is my first post to the forum but I must say I am impressed with how much information is available so it wont be my last.

    I own a 2002 WRX Wagon and I have had no problems with it over the last three years. However, this last week my car started giving me a ton of issues. Hopefully some of you might be able to help me.

    Last week my power steering went out. A few days later I noticed that my panels were acting really strange. The MPH gauge and RPM Gauge would go down to 0 and then shoot back up to their respective numbers, then my radio started turning off for a few seconds and then turn back on. Sure enough the next day my car wouldnt start. After a quick jump my car would get going again. The next day I jumped the car and When I started moving at a green light my car stopped responding to the gas pedal, the engine would fail to rev and it would clunk around. I turned the car off and pushed it to a curb on the side of the road.

    So in total, my battery is dead, gauges are faulty, gas pedal gives no response, and my power steering is out.

    Any ideas...

    Thank You All.

    -Dennis

    BTW: On my panel the E-Brake and Battery light were both on whenever I would drive my car. The E-Brake was down so I dont know what is causing this.

    bad grounds can cause most of the symptoms described as well. as far as the ebrake light being on you could just be low on brake fluid. when the light is on and you pull the ebrake lever does the light appear to get a little brighter with the e brake pulled up? if it gets brighter then the light you see when the ebrake is down is for the low brake fluid warning. so check your belts check all your fluids and check your grounds on the battery to the car, the battery to the block, the grounds from the harness to the block, and the grounds from the block to the car.

    hope that helps-
    bobby
    bobby@preracing.com
    Performance Race Engineering
    503-619-0055

    preracing.com
    Follow us on Twitter
    Friend us on MySpace

  7. #6
    Registered User
    Join Date
    May 2010
    Posts
    2
    Thank you for all of the help guys. Its downpouring out here so I will wait until tomorrow to check the belts.

    I am not the most mechanically experienced person but I am going to try my hardest to fix this on my own. Any strange tools I might need?

    Also, could the belt affect the gas pedal response?

    Thanks Again.

    -Dennis

  8. #7
    Registered User 2.0Rs's Avatar
    Join Date
    Jul 2007
    Location
    King of Prussia, Pa
    Posts
    1,168
    The brake light is because of low fluid. It only comes on when the e-brake is up or low fluid. At that point I'd check out the condition of your brakes. It is possible to have decent pad left and just be low enough to make it come on. Add just a little bit but don't top it off to max. If you do then it'll be harder to tell when your brakes are running low before the squeeler makes noise. Also then when you put on new pads the fluid will over flow all over the place when you compress the pistons.

  9. #8
    Toboggan T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Your Mommas
    Posts
    25,514
    I Support ClubWRX
    Your alternator is bad. Change it and the belts, more than likely your problem will go away. As for the power steering it could be the belt or the pump could just be bad. The brake light is more than likely a result of the charging system but just in case check your brake fluid. If your brake fluid is low do not add fluid!!! Replace your brake pads and flush your fluid with new


    Lead Wrench @ WTF Tuning, LLC

  10. #9
    Registered User 2.0Rs's Avatar
    Join Date
    Jul 2007
    Location
    King of Prussia, Pa
    Posts
    1,168
    Quote Originally Posted by LPPTundWRX View Post
    Your alternator is bad. Change it and the belts, more than likely your problem will go away. As for the power steering it could be the belt or the pump could just be bad. The brake light is more than likely a result of the charging system but just in case check your brake fluid. If your brake fluid is low do not add fluid!!! Replace your brake pads and flush your fluid with new
    Uneven wear on the pads from side to side for some reason uses a lot of brake fluid. I've had cars with 6/32's on them with the brake light on. Only thing to do is add just a little bit of fluid. Never do I fill it to max. Just enough so it still does what it's supposed to do.

  11. #10
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,968
    I Support ClubWRX
    Quote Originally Posted by 2.0Rs View Post
    The brake light is because of low fluid. It only comes on when the e-brake is up or low fluid. At that point I'd check out the condition of your brakes.
    The E-brake light comes on when voltage is low for some reason.
    Last edited by Donkey; 05-11-2010 at 05:47 AM.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  12. #11
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,968
    I Support ClubWRX
    Quote Originally Posted by dholland View Post

    Also, could the belt affect the gas pedal response?
    This is kinda a no brainer. Yes. Your car needs a certain voltage to run correctly as well as needing electricity period. So no electricity or falling voltage = car not wanting to go = hesitant gas pedal.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •