02 wrx wagon belt squeel
+ Reply to Thread
Results 1 to 6 of 6

This is a discussion on 02 wrx wagon belt squeel within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; i have an 02 wrx wagon with 90k and its 100% stock about a week ago i started to get ...

  1. #1
    Registered User
    Join Date
    May 2010
    Location
    NY
    Posts
    15

    Question 02 wrx wagon belt squeel

    i have an 02 wrx wagon with 90k and its 100% stock

    about a week ago i started to get a loud squealing on startup, i know it has to do with the belts.
    sometimes the squealing starts as soon as the car starts, however sometimes it doesn't start til i turn the weel.
    sounds like power steering right?
    the squealing also is directly correlated with the rpms, so as i rev it gets louder.


    now on top of this i am getting this chirping sound while cruising around 2500 rpms and up, sounds like the belt is slipping. however when i hear the chirp my car bogs down right with it for a split seccond. wtf is this?

    i also feel like my boost isnt smooth for lack of a better description. so when i accelerate and i know im on boost the power feels somewhat choppy. maybe this part is just in my head.


    any ideas on the chirp and or belt issue? are they or are they not related?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Replace your belts and see if it fixes the problem. If not, report back and we'll go from there.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  4. #3
    Registered User
    Join Date
    May 2010
    Location
    NY
    Posts
    15
    im replacing them this coming thursday
    i will post back

    thanks

  5. #4
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by jzito View Post
    im replacing them this coming thursday
    i will post back

    thanks
    No prob, and have fun.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  6. #5
    Registered User
    Join Date
    May 2010
    Location
    NY
    Posts
    15
    sorry havent been back for a few weeks, computer ate dirt

    anyways new belts fixed it thx!

  7. #6
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Good to hear, the loss of power could have been due to your alternator loosing it's charging ability for that split second, but at least it's fixed now.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •