boost cut out
Results 1 to 4 of 4

This is a discussion on boost cut out within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; the rpms go to 4500 and will not go any higher with out really struggling. it still spools up but ...

  1. #1
    Registered User
    Join Date
    Jan 2010
    Posts
    13

    boost cut out

    the rpms go to 4500 and will not go any higher with out really struggling. it still spools up but no power, its also making a real loud hissing noise when it spools up like a pipe is off which it could be havent looked yet its raining out. any ideas? thanks for any help

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Mar 2009
    Posts
    6
    Quote Originally Posted by domestics-only View Post
    the rpms go to 4500 and will not go any higher with out really struggling. it still spools up but no power, its also making a real loud hissing noise when it spools up like a pipe is off which it could be havent looked yet its raining out. any ideas? thanks for any help
    You have a pressure leak somewhere or your turbo is going. How many miles on your car?? What year??

  4. #3
    Registered User
    Join Date
    Jan 2010
    Posts
    13
    i have 110k miles and its an 04

  5. #4
    Registered User
    Join Date
    Mar 2009
    Posts
    6
    Quote Originally Posted by domestics-only View Post
    i have 110k miles and its an 04
    I believe you have a bad turbo with that many miles. Ive talked with a lot of people and usually the turbo will go out at around 75000 miles or so. It will hiss pretty loud when its going bad. Other than that, I would guess there is a leak somewhere. My 04 is sitting in the garage without an engine so its alittle easier to pinpoint what might be wrong. Im driving an 09 now, so its pretty similar except for the 2.5 L in it. Depending on what kind of mods, you can get a way with a blouch 16G, large or small. I was running the 16G smaller version which was tuned to 19PSI. The tuner pretty much destroyed my engine as it had 141,000 before the rod broke on the dyno. He claimed it wasnt his fault. (FASTWRX.com sucks!!) Extremely horrible service!! Stay away from them. Oakos.com is a great place to get parts.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •