CEL O2 sensor help
Results 1 to 3 of 3

This is a discussion on CEL O2 sensor help within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I just bought my rex a few months ago. When I bought it there was a CEL showing a bad ...

  1. #1
    Registered User Weaver's Avatar
    Join Date
    Mar 2010
    Location
    Maryland
    Posts
    96

    CEL O2 sensor help

    I just bought my rex a few months ago. When I bought it there was a CEL showing a bad front O2 sensor. I got my mechanic to put a new one on there and the code is still coming up as a bad o2 sensor. It already had Apexi exhuast from the turbo. Anyone know what I can do to get this O2 CEL, I have to get it passed emissions?
    Last edited by Weaver; 05-02-2010 at 12:48 AM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,104
    I Support ClubWRX
    The front O2 sensor is in the passenger side ehxaust manifold. Your TBE has nothing to do with it.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  4. #3
    Registered User Weaver's Avatar
    Join Date
    Mar 2010
    Location
    Maryland
    Posts
    96
    i put the stock downpipe on becuase of emissions and the cel didnt come on as fast as usual tho. i didnt see another O2 sensor during the install tho. your saying there is another on the exhuast manifold? im not to familiar with the exhuast systems for scoobs yet
    Last edited by Weaver; 05-03-2010 at 09:42 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •