Cruise Control Issue
+ Reply to Thread
Results 1 to 14 of 14

This is a discussion on Cruise Control Issue within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hello, so I just bought a 2002 Subaru Impreza WRX, runs amazing, everything mechanical works great Only problem is that ...

  1. #1
    Registered User Mark_02WRX's Avatar
    Join Date
    Apr 2010
    Location
    Casa Grande, AZ
    Posts
    56

    Cruise Control Issue

    Hello, so I just bought a 2002 Subaru Impreza WRX, runs amazing, everything mechanical works great

    Only problem is that the cruise control doesn't work for some reason. I took a look at all the fuses and there weren't any that related to cruise control, they all looked good too, none were blown.

    Anyone else ran into this problem before?? Any help would be great

    TIA,
    Mark

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User BugEye'd's Avatar
    Join Date
    Apr 2010
    Location
    Where ever the army sends me
    Posts
    16
    hey, ive got the same problem in my 03 wrx... i havent looked too deep into it. my light comes on when i turn on my cruise but it doesnt actually work. the only thing i could ever think of is that a relay or something along those lines has gone bad....if you do figure it out let me know

  4. #3
    Registered User Mark_02WRX's Avatar
    Join Date
    Apr 2010
    Location
    Casa Grande, AZ
    Posts
    56
    YEUUP! Same here, I flick the switch and the light comes on aswell but no cruise control. I was just outside under the hood and I even took a look at the cruise control module and lines that lead to the throttle body and they look fine, wierd.

  5. #4
    Registered User BugEye'd's Avatar
    Join Date
    Apr 2010
    Location
    Where ever the army sends me
    Posts
    16
    yea i dont get it... but right now my cruise is the least of my worries lol. but i dont get it...hopefully someone else will have an answer, but i am still looking. have faith, the guys here do have a lot of answers.

  6. #5
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Id say its a relay...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  7. #6
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Quote Originally Posted by Mark_02WRX View Post
    Hello, so I just bought a 2002 Subaru Impreza WRX, runs amazing, everything mechanical works great

    Only problem is that the cruise control doesn't work for some reason. I took a look at all the fuses and there weren't any that related to cruise control, they all looked good too, none were blown.

    Anyone else ran into this problem before?? Any help would be great

    TIA,
    Mark
    Do you hear any clicking of any kind when you press the cruise button to ON ? How many miles are on the vehicle? Did you check to see if the cable is intact, routed properly, and still attached to the lever on the side of the throttle body? Did you have the cruise control clip recall performed?

  8. #7
    Registered User Mark_02WRX's Avatar
    Join Date
    Apr 2010
    Location
    Casa Grande, AZ
    Posts
    56
    Quote Originally Posted by EvoEatr View Post
    Do you hear any clicking of any kind when you press the cruise button to ON ? How many miles are on the vehicle? Did you check to see if the cable is intact, routed properly, and still attached to the lever on the side of the throttle body? Did you have the cruise control clip recall performed?
    I do hear a click when I push the button and the car has 110,000+ miles, yes I have looked at the Cruise Control module and everything is intact just fine, all the cables are attached and everything look as if it hasn't been touched, even the cable that leads to the throttle body. Lastly, no I haven't had the Cruise Control Clip Recall performed :/

  9. #8
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Quote Originally Posted by Mark_02WRX View Post
    I do hear a click when I push the button and the car has 110,000+ miles, yes I have looked at the Cruise Control module and everything is intact just fine, all the cables are attached and everything look as if it hasn't been touched, even the cable that leads to the throttle body. Lastly, no I haven't had the Cruise Control Clip Recall performed :/
    So the switch will turn on, you hear the clicking noise however when you go to set the cruise control it wont set? You are above around 40 mph right? I would check the stop light switch and the clutch switch both which disable the cruise control when pressed, Sometimes the little pad for the pintle in the switch wears out, and if this happens the cruise control will not be allowed to set..
    Last edited by EvoEatr; 04-17-2010 at 10:18 PM.

  10. #9
    Registered User Mark_02WRX's Avatar
    Join Date
    Apr 2010
    Location
    Casa Grande, AZ
    Posts
    56
    Quote Originally Posted by EvoEatr View Post
    So the switch will turn on, you hear the clicking noise however when you go to set the cruise control it wont set? You are above around 40 mph right? I would check the stop light switch and the clutch switch both which disable the cruise control when pressed, Sometimes the little pad for the pintle in the switch wears out, and if this happens the cruise control will not be allowed to set..
    Yes I'm well above 40 when trying to set it. And I actually thought of that too regarding the switch and all, I'll look into it. Thanks!!

  11. #10
    Registered User
    Join Date
    Mar 2008
    Posts
    8
    would a check engine light make cruise not work? or that thing on the tranny?mine stop working when i broke that connector.. never got arround to trouble shoot or fix it..

  12. #11
    Registered User kbrownmann's Avatar
    Join Date
    Nov 2009
    Location
    Melbourne, Kentucky, United States
    Posts
    551
    yes on a subaru the cel disables the cruise control. is yours on?
    Hawk-Eye Alliance #Infinity

  13. #12
    Registered User BugEye'd's Avatar
    Join Date
    Apr 2010
    Location
    Where ever the army sends me
    Posts
    16
    my cruise doesnt do anything but light up....doesnt matter if my CEL is on or not. any ideas with me? its the same problem everything looks good from what i have checked out
    "Only the dead have seen the end of war"
    - Plato

  14. #13
    Registered User
    Join Date
    Oct 2010
    Posts
    43
    Any updates on this? im having the same issue.

  15. #14
    Registered User
    Join Date
    Jul 2003
    Location
    Houston
    Posts
    28
    When the clutch pedal is depressed, a small button/switch extends and disengages cruise control. When you release the pedal, the button is then pressed allowing cruise control to be engaged. Mounted on the arm of the clutch pedal is a small white grommet made of plastic that engages the button. If that grommet breaks, the button is never pressed by the clutch pedal arm, so the car thinks that the clutch pedal is depressed for the purposes of cruise control and cruise control never turns on. If you are missing this grommet, this is a simple fix. Buy the small plastic/rubber piece and stick it in the small opening in the clutch arm. Or stick a screw in the hole, and fasten a nut to it. Here is a link describing the same solution and may help you understand what is going on. Cruise control problem

    and here is another thread on nasioc. Cruise control - NASIOC

    The part number is 36036AC010. I am spending the few dollars for the part and shipping because i'm worried if I pick a screw that is too big, the clutch pedal won't be resting in the right spot and that might wear out the clutch.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •