My 03 wrx not runnin quite right
Results 1 to 15 of 15

This is a discussion on My 03 wrx not runnin quite right within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I have an 03 wrx with turbo back 3" exhaust and cold air intake. I've been driving with this setup ...

  1. #1
    Registered User
    Join Date
    Apr 2010
    Posts
    4

    My 03 wrx not runnin quite right

    I have an 03 wrx with turbo back 3" exhaust and cold air intake. I've been driving with this setup for over a year. Lately when I'm driving and it gets to about 4 grand it will start to sputter and sometimes die when I stop. It doesn't always do it and when it does i can just shut it off and then start it back up and it will run just fine. I had a buddy scan it and the only code that came up was the o2 censor, but thats been an issue since I changed the exhaust. anybody got any ideas?
    Last edited by herb86; 04-16-2010 at 03:40 PM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User oguitar's Avatar
    Join Date
    Nov 2009
    Location
    Albuquerque, New Mexico, United States
    Posts
    1,021
    How many miles?

    Have you kept up with all scheduled maintenance?
    Life is like riding a bicycle in order to keep your balance you must keep moving.

  4. #3
    Registered User
    Join Date
    Apr 2010
    Posts
    4
    Quote Originally Posted by oguitar View Post
    How many miles?

    Have you kept up with all scheduled maintenance?
    It has 95k and the only maintenance I have done is new plugs. It was doing it before I put the plugs in, I thought it might just need a tune up, but it didn't make a difference. I'm gonna try the fuel filter tomorrow and take apart the intake and check for air leaks. I also cleaned the mass air flow censor the other day.

  5. #4
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    At that many miles I'm guessing it's a fuel filter issue. Check your plugs just to make sure they are still okay though.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  6. #5
    Toboggan T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Your Mommas
    Posts
    25,514
    I Support ClubWRX
    If your o2 light is on that means you have no engine management and your running a turbo back? Also bad.

    Replace fuel filter for sure, may be other issues as well


    Lead Wrench @ WTF Tuning, LLC

  7. #6
    Registered User KoreanBeefcake's Avatar
    Join Date
    Jul 2003
    Location
    Huntsville, Alabama (formerly WA)
    Posts
    3,003
    hmm... i had a similar issue. i ended up getting new spark plugs, new fuel filter, and re-greased my BOV, and just check for boost/vaccum leaks.


    its been good since then. not sure what exactly fixed it.

  8. #7
    Registered User
    Join Date
    Apr 2010
    Posts
    4
    Quote Originally Posted by LPPTundWRX View Post
    If your o2 light is on that means you have no engine management and your running a turbo back? Also bad.

    Replace fuel filter for sure, may be other issues as well
    Do you think that I should put the original exhaust back on it?

  9. #8
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by herb86 View Post
    Do you think that I should put the original exhaust back on it?
    The 03 WRX works okay with a new TBE, unlike other model years. You don't NEED engine management, but you should get some form so you can actually take advantage of the gains that the TBE provides, plus you can turn off that annoying check engine light for the cat efficiency.

    I really don't think this issue is related to the exhaust, but if you attempt any of the fixes we outline here and nothing helps, it couldn't hurt to try to put it back on, reset the ECU and see if that helps.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  10. #9
    Registered User oguitar's Avatar
    Join Date
    Nov 2009
    Location
    Albuquerque, New Mexico, United States
    Posts
    1,021
    My advice to you is to perform the 90k mile service. Do it yourself and save money. You can run a downpipe with out engine management but I don't recommend it. You might need an uppipe if it is still stock.

    Your o2 sensor could need to be replaced but try and get a code pulled.
    Life is like riding a bicycle in order to keep your balance you must keep moving.

  11. #10
    Registered User
    Join Date
    Apr 2010
    Posts
    4
    Quote Originally Posted by Anub1s View Post
    The 03 WRX works okay with a new TBE, unlike other model years. You don't NEED engine management, but you should get some form so you can actually take advantage of the gains that the TBE provides, plus you can turn off that annoying check engine light for the cat efficiency.

    I really don't think this issue is related to the exhaust, but if you attempt any of the fixes we outline here and nothing helps, it couldn't hurt to try to put it back on, reset the ECU and see if that helps.
    What do I have to do to get engine management? $$?

  12. #11
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by herb86 View Post
    What do I have to do to get engine management? $$?
    Lot's of options here, and yes they cost money. If you have someone near you with a Tactrix cable that's willing to help you, they could flash an open source map to your car, whether or not they will charge you is up to them.

    If you wish to go the open source tuning method yourself, it's ~$150 for a Tactrix cable and the software is free, you will have to find a tune to use though, or do it yourself, which I'm guess you're not going to want to do. This is the method I use.

    Secondly, there's the ever popular AccessPort, which can be had for $700 brand new, or you can get a used older V1 model or V2 model for cheaper. I've seen V1's go for around $350-450. More expensive option to be sure, but it recieves a lot of praise.

    There's also other stand alone and piggy back systems, but those are a bit more involved as well as a bit more money.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  13. #12
    Toboggan T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Your Mommas
    Posts
    25,514
    I Support ClubWRX
    Quote Originally Posted by herb86 View Post
    Do you think that I should put the original exhaust back on it?
    Id just suggest getting a tune and going stage 2. If it was me Id take off the aftermarket downpipe til you get the tune. But I am anal and thats just me.


    Lead Wrench @ WTF Tuning, LLC

  14. #13
    Toboggan T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Your Mommas
    Posts
    25,514
    I Support ClubWRX
    why not buy a wagon?


    Lead Wrench @ WTF Tuning, LLC

  15. #14
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by LPPTundWRX View Post
    why not buy a wagon?
    I'm going to assume that this was not meant for this thread
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  16. #15
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,967
    I Support ClubWRX
    What CAI are you using? What is the exact code #?
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •