question about my 03 wrx.
Results 1 to 12 of 12

This is a discussion on question about my 03 wrx. within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; hey everyone, im not sure the best way to explain my problems im having with my wrx but im going ...

  1. #1
    Registered User BugEye'd's Avatar
    Join Date
    Apr 2010
    Location
    Where ever the army sends me
    Posts
    16

    question about my 03 wrx.

    hey everyone, im not sure the best way to explain my problems im having with my wrx but im going to give it a shot. hopefully someone will understand me and give me some sort of an idea whats going on.

    when i am sitting at idle she flux's greatly, almost to the point of stalling, and even stalling sometimes. the CEL comes on and off randomly, autozone is saying she is either running rich or lean (yes it changes like that) in bank one. she is also eating oil horribly. when i had the oil changed last, the tech said that it could be the turbo seals. i havent had the time to pull off my intercooler to check if there is any oil there. thats what the tech said to do.

    any help would be great. thanks for the help!!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Are you getting any smoke or is it leaking at all?
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  4. #3
    Registered User BugEye'd's Avatar
    Join Date
    Apr 2010
    Location
    Where ever the army sends me
    Posts
    16
    ill get some smoke when i down shift and get on it, but other than that no. from what i can see there is no smoking what so ever.

  5. #4
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Quote Originally Posted by BugEye'd View Post
    ill get some smoke when i down shift and get on it, but other than that no. from what i can see there is no smoking what so ever.
    Your either mis firing or you are loosing compression in 1 of the cylenders and if that's the case your piston rings are almost gone...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  6. #5
    Registered User BugEye'd's Avatar
    Join Date
    Apr 2010
    Location
    Where ever the army sends me
    Posts
    16
    well that sucks, but it explains why im losing oil. how bad is it to replace the rings yourself. or is it better to have a mechanic do it?

  7. #6
    Banned
    Join Date
    Dec 2003
    Location
    Dallas, TX / Sterling, VA
    Posts
    6,629
    I Support ClubWRX
    Quote Originally Posted by BugEye'd View Post
    well that sucks, but it explains why im losing oil. how bad is it to replace the rings yourself. or is it better to have a mechanic do it?
    How much oil are you losing?

    Rings involve pulling the engine. And if it's bad enough, replacing or honing the entire shortblock. If you have a broken ring then you have a broken piston. Either way, plan on a few thousand dollars unless you can do it all yourself and it's on the lower end of the damage spectrum.

    Check your intercooler for blow-by.

  8. #7
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Quote Originally Posted by BugEye'd View Post
    well that sucks, but it explains why im losing oil. how bad is it to replace the rings yourself. or is it better to have a mechanic do it?
    If your gonna do that just rebuild the whole motor cause its gonna be the same amount in labor...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  9. #8
    Registered User BugEye'd's Avatar
    Join Date
    Apr 2010
    Location
    Where ever the army sends me
    Posts
    16
    over time i lose it all. i drove from sierra vista AZ to Houston TX, its about a 1500 mile trip, when i got to Houston i virtually no oil.

  10. #9
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Quote Originally Posted by BugEye'd View Post
    over time i lose it all. i drove from sierra vista AZ to Houston TX, its about a 1500 mile trip, when i got to Houston i virtually no oil.
    Yep your motors on its last nut...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  11. #10
    Registered User BugEye'd's Avatar
    Join Date
    Apr 2010
    Location
    Where ever the army sends me
    Posts
    16
    so i just went out and checked my oil. i had it changed about two weeks ago..and just drove about 600 miles, back to Houston from my home town in Florida. my oil level is so low that its barely reading on my dip stick....if it is my pistons....then i want to get rid of her....are there any other causes for this?

  12. #11
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Quote Originally Posted by BugEye'd View Post
    so i just went out and checked my oil. i had it changed about two weeks ago..and just drove about 600 miles, back to Houston from my home town in Florida. my oil level is so low that its barely reading on my dip stick....if it is my pistons....then i want to get rid of her....are there any other causes for this?
    Not unless its been leaking and you have a bad tune.... how is your mpg?
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  13. #12
    Registered User BugEye'd's Avatar
    Join Date
    Apr 2010
    Location
    Where ever the army sends me
    Posts
    16
    im not 100% sure how well the mpg is when everything is running normally, but i made it from ft walton beach florida to houston tx 607 miles on a tank and 3/4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •