Clutch or Engine issue?
Results 1 to 2 of 2

This is a discussion on Clutch or Engine issue? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I own a 2003WRX hatchback, just stock at the moment (160,000kms) I'm starting to sense a mild hesitation or a ...

  1. #1
    Registered User
    Join Date
    Oct 2009
    Location
    Milton
    Posts
    10

    Clutch or Engine issue?

    I own a 2003WRX hatchback, just stock at the moment (160,000kms)

    I'm starting to sense a mild hesitation or a slight pulsing sensation as I accelerate. ( I think I might of felt it as I've let of the gas as well, but not 100% sure)It doesn't seem to be there once I'm cruising at a constant speed. It seems like it has been getting worse the last few weeks? I'm wondering if its a A/F issue, sensor issue or Clutch problem. Wouldn't the car sense potential engine issues and put the check engine light on? This is why I'm wondering if it might be a clutch problem? I was told the clutch was recently rebuilt, but it looks like previous owner tried to do things on his own and wasn't the greatest mechanic?

    Thanks

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User benson156's Avatar
    Join Date
    Sep 2008
    Location
    Utah
    Posts
    331
    Sounds like what my car felt like when my clutch was slipping, I hope you get things figured out man.
    Hawk-eye Alliance #156

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •