Loud cabin after having a/c work done
Results 1 to 4 of 4

This is a discussion on Loud cabin after having a/c work done within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I just recently took my car to a well known mechanic to get my a/c fixed. The main problem was ...

  1. #1
    Registered User zeus32's Avatar
    Join Date
    Mar 2010
    Location
    Albuquerque NM
    Posts
    37

    Loud cabin after having a/c work done

    I just recently took my car to a well known mechanic to get my a/c fixed. The main problem was my regulator valve; it was clogged. They said they had to take my whole dash off to replace this valve. After being in the shop for three days i finally got her back. When i get in and adjust my steering wheel it was uneasy to move up and down. It also wobbled to the left and right when adjusting it but when i lock it in place it stays tightly. Also my ****pit is much louder. I hear the turbo spooling up much much louder and I also hear other engine noises that sound normal but have never been able to hear them before from inside. The noises seem like they are coming from underneath the steering wheel near the pedals. i was thinking they didn't replace the insulation right. Sorry for the long post, please let me know if you have any ideas why I hear all this noise all the sudden.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    There's a rubber grommet down there in the firewall, check to see if that's still in place. They may have removed it for whatever reason. Best to just check for any hole in general though.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  4. #3
    Registered User zeus32's Avatar
    Join Date
    Mar 2010
    Location
    Albuquerque NM
    Posts
    37
    Quote Originally Posted by Anub1s View Post
    There's a rubber grommet down there in the firewall, check to see if that's still in place. They may have removed it for whatever reason. Best to just check for any hole in general though.
    Thank you, do you think they may have not replaced the insulation right?

  5. #4
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by zeus32 View Post
    Thank you, do you think they may have not replaced the insulation right?
    Not sure what insulation you're referring to. There's some insulation on the engine bay side of the firewall towards the bottom, but that shouldn't have been touched. I'm thinking they removed a plug or grommet that they just forgot to put back in, though I'm not sure why they would have removed it in the first place.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •