Sudden gas mileage problems. - Page 2
+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 16 to 23 of 23

This is a discussion on Sudden gas mileage problems. within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Originally Posted by EvoEatr I can also say that Subarus are extremely touchy when it comes to certain aftermarket components, ...

  1. #16
    Registered User
    Join Date
    Apr 2010
    Posts
    12
    Quote Originally Posted by EvoEatr View Post
    I can also say that Subarus are extremely touchy when it comes to certain aftermarket components, axles,thermostats, ignition components etc etc...I have seen brand new aftermarket plugs and wires cause dead misfires on subarus before...not saying this is your problem just thought I would mention it...
    EvoEatr,

    If anythng is aftermarket its those plugs and the K&N filter I installed, and those have been in there for 20k miles.. I could see how a clogged K&N filter could cause deminising trouble.. but not sudden like this was...

    Maybe it would help to mention that my exhaust sound hasn't been quite the same since that day... I really should have mentioned that sooner.

    Guys (or Gals, who knows on the internet anymore).. Thanks for the attention to my post, I really really appreciate it!!!!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Quote Originally Posted by NFACurious View Post
    Maybe I should invest in one of those books, I used to be real into cars years ago, but machinework and the lack of desire to understand engines took over, because I read that comment and all I can say is... whaaa? Nothing against 06scoobyrex, its all my ignorance.

    Havening witnessed a slipping clutch in my first car, honda '92 accord dx (I miss that ride, 40mpg on the highway) My wrx 30 mph in 3rd has no hesitation on acceleration.

    Sorry It took me too long to respond 06scoobyrx, but yes I have the platinum ones, what are the iridium costing???

    When they pulled my plugs to change the new ones, I asked and they reported "normal wear"..

    So now my deductions of problems leads me to, a bad o2 sensor that for some reason should be throwing a code but isn't, a crappy set of plugs that should have lasted longer than this and should not have failed so suddenly, or somehow that minor injury to the cat shield caused troubles up the line to the engine (waste gate etc) that being the first time under that car I could not identify...

    Am I crazy? I feel like going crazy and pulling all my hair out...
    its okay... you might have loosened a fuel line when you bottomed out and you might be loosing pressure in your lines... im sure if your 02 were bad your car would be running like **** + your cel would be on... iridium for ngk iridium are 8.49 a piece... ive had my rex for like 4 months and at first i put in platinums and it ran like **** then i put in the iridiums in and now it runs a lot better now...
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  4. #18
    Registered User 06scoobyrex's Avatar
    Join Date
    Feb 2010
    Location
    SL,UT
    Posts
    2,606
    Quote Originally Posted by NFACurious View Post
    EvoEatr,

    If anythng is aftermarket its those plugs and the K&N filter I installed, and those have been in there for 20k miles.. I could see how a clogged K&N filter could cause deminising trouble.. but not sudden like this was...

    Maybe it would help to mention that my exhaust sound hasn't been quite the same since that day... I really should have mentioned that sooner.

    Guys (or Gals, who knows on the internet anymore).. Thanks for the attention to my post, I really really appreciate it!!!!
    also check your tire pressure and your air filter
    Hawk-Eye Alliance #801
    The Impreza "this was repaired/replaced at what mileage" database (Please Contribute)
    http://www.clubwrx.net/forums/showth...57#post2688257

  5. #19
    Registered User
    Join Date
    Apr 2010
    Posts
    12
    Quote Originally Posted by 06scoobyrex View Post
    also check your tire pressure and your air filter
    Tires are filled with nitrogen and checked pretty often, probably do need to check the air filter as thats a pain to get to..

  6. #20
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Quote Originally Posted by NFACurious View Post
    Tires are filled with nitrogen and checked pretty often, probably do need to check the air filter as thats a pain to get to..
    Air filters are cake on any modern Subaru... just unclip the airbox and pull the filter out...You might also want to try cleaning your MAF sensor...

  7. #21
    Registered User
    Join Date
    Apr 2010
    Posts
    12
    Quote Originally Posted by EvoEatr View Post
    Air filters are cake on any modern Subaru... just unclip the airbox and pull the filter out...You might also want to try cleaning your MAF sensor...
    Lol I had a helluva time with it... If I wasn't under the thumb this weekend I might actually get to try all these ideas..

  8. #22
    Registered User
    Join Date
    Apr 2010
    Posts
    12

    remebered something else

    When getting off the gas when the turbo guage is above 10 oclock (9 oclock being zero of course) It now sounds like I have a BOV, small one anyways, can't hear it with the radio on. The car used to just make a very light *ch* sound.

  9. #23
    Registered User
    Join Date
    Apr 2010
    Posts
    12

    Apologies

    Sorry about the post about noises, I know those aren't helpfull, now. All I can say is the turbo IS noisier than usual...

    Any Ideas?

    Thanks guys/gals, really appreciate it.

    Once I get another daily driver, expect me back here for consults on aftermarket upgrades!

+ Reply to Thread
Page 2 of 2 FirstFirst 12

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •