Botched Gauge Install
Results 1 to 4 of 4

This is a discussion on Botched Gauge Install within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hello all, I attempted to install my Prosport Mech Boost gauge yesterday afternoon, replacing the stock one. And I could ...

  1. #1
    Registered User FaaipDeOiad's Avatar
    Join Date
    Apr 2009
    Location
    Springfield
    Posts
    11

    Unhappy Botched Gauge Install

    Hello all,

    I attempted to install my Prosport Mech Boost gauge yesterday afternoon, replacing the stock one. And I could never get it to turn on the secondary light color when you turn on your running lights. As far as I could tell there was never voltage on that wire.

    And now my daytime running lights don't turn on and my running lights wont turn off. I have to pull the fuse on the inside fuse box so I don't run down my battery. I checked all the fuses and there is nothing blown. And I also disconnected the gauge. A friend told me I might have shorted a module out.

    I dont know where to look from here. Help!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    What year is the vehicle? I believe some of the newer Subarus if you go cutting and splicing and such could screw things up...Which wires did you tap into?...The first computer in the car that comes to mind is the BIU...

  4. #3
    Registered User FaaipDeOiad's Avatar
    Join Date
    Apr 2009
    Location
    Springfield
    Posts
    11
    Its an 04. It turned out to be that damn switch on the top of the steering column. What is the point of that?? And all my other symptoms have gone away. I think it was a result of pulling all the fuses to check them. Everything is running tip top now.

  5. #4
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Quote Originally Posted by FaaipDeOiad View Post
    Its an 04. It turned out to be that damn switch on the top of the steering column. What is the point of that?? And all my other symptoms have gone away. I think it was a result of pulling all the fuses to check them. Everything is running tip top now.
    The point of that switch is to keep the parking lights on when the key is out of the ignition...I have always thought it is for off road use...I usually call it a virgin switch lol

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •