Clunk noise, 2006 STI
+ Reply to Thread
Results 1 to 7 of 7

This is a discussion on Clunk noise, 2006 STI within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hello everybody! I've been in the market of buying an STI for a while now, and i found an 2006 ...

  1. #1
    Registered User
    Join Date
    Apr 2010
    Posts
    4

    Clunk noise, 2006 STI

    Hello everybody!

    I've been in the market of buying an STI for a while now, and i found an 2006 STI at a dealer, i took it for a test drive and theres a clunking noise from the rear, possibly left rear.

    Just as you stop or drive off it goes clunk, but not as you shift or go on and of the gas...

    after the test drive i wiggled the rear wheel pretty good (im a big guy) and couldn't feel anything lose. Also feelt the rims and brake disc and it didnt feel like any side was getting hotter.

    Feel like i narrowed it down to strut or diff, anybody have any other ideas / had the same problem?

    I told the dealer i would buy it IF they either fixed it or found out what was wrong and lowered the price accordingly!

    Just wanted to get a second opinion before i go there again tomorrow (Sorry, im a bit late i guess).

    Any answer is greatly appreciated
    /Raffi

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Quote Originally Posted by RAFARO View Post
    Hello everybody!

    I've been in the market of buying an STI for a while now, and i found an 2006 STI at a dealer, i took it for a test drive and theres a clunking noise from the rear, possibly left rear.

    Just as you stop or drive off it goes clunk, but not as you shift or go on and of the gas...

    after the test drive i wiggled the rear wheel pretty good (im a big guy) and couldn't feel anything lose. Also feelt the rims and brake disc and it didnt feel like any side was getting hotter.

    Feel like i narrowed it down to strut or diff, anybody have any other ideas / had the same problem?

    I told the dealer i would buy it IF they either fixed it or found out what was wrong and lowered the price accordingly!

    Just wanted to get a second opinion before i go there again tomorrow (Sorry, im a bit late i guess).

    Any answer is greatly appreciated
    /Raffi
    Somewhat common problem with the STI...Chances are you need rear struts....Do a search on here you should find tons of information... AH and Welcome to ClubWRX!

  4. #3
    Registered User
    Join Date
    Apr 2010
    Posts
    4
    Thanks for you answer EvoEatr, I did some more searching and like you said it's probably the struts.

    And I just got a call from the dealer, he said they were going to change the rear springs, he was a sales rep, so I guess he means the struts?!

    Hopefully I will be a STI owner tomorrow!

  5. #4
    Registered User tarmacsti's Avatar
    Join Date
    Dec 2007
    Location
    South Africa, Jo'burg
    Posts
    862
    I have the same problem, and spoken to a couple of guys... replacing them would solve the problem but it will return.
    **__The Hawk-Eye Alliance__**
    Member #0135

  6. #5
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Quote Originally Posted by RAFARO View Post
    Thanks for you answer EvoEatr, I did some more searching and like you said it's probably the struts.

    And I just got a call from the dealer, he said they were going to change the rear springs, he was a sales rep, so I guess he means the struts?!

    Hopefully I will be a STI owner tomorrow!

    Sometimes the problem does return, sometimes not ( at least in my experience with this problem)...Wish you the best of luck if all goes well with the purchase...Do an extensive test drive again before purchase though just to make sure nothing else is array...

  7. #6
    Registered User tarmacsti's Avatar
    Join Date
    Dec 2007
    Location
    South Africa, Jo'burg
    Posts
    862
    And come post pics afterwards!
    **__The Hawk-Eye Alliance__**
    Member #0135

  8. #7
    Registered User
    Join Date
    Apr 2010
    Posts
    4
    Im going to take the second test drive in a couple of hours, hopefully everything is A-OK.

    Yes will put some pics up! (if I can resist not getting out of it to take them )

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •