2004 Impreza Starting Issues Help Please!
Results 1 to 4 of 4

This is a discussion on 2004 Impreza Starting Issues Help Please! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Thanks I'll try it today and get back....

  1. #1
    Registered User
    Join Date
    Mar 2010
    Posts
    2

    2004 Impreza Starting Issues Help Please!

    Thanks I'll try it today and get back.
    Last edited by gosteep24; 03-17-2010 at 08:18 AM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    A shot from the hip... it does sound like the plunger in the little "neutral start switch" above the clutch pedal is sticking....Sometimes if you lube it a tad it might loosen things up..

  4. #3
    Registered User 68sprintb's Avatar
    Join Date
    Dec 2005
    Location
    Cupertino, CA
    Posts
    434
    Definitely sounds like the clutch switch sticking. They're pretty easy to get to, so if you can remember to make sure the transmission is in neutral before starting the car you can just bypass the switch entirely if it keeps acting up.
    Blobeye Syndicate #75
    2005 OBP WRX Sport Wagon
    Stewart Warner Boost & Oil temp gauges / OEM 20 mm rear bar
    Cobb stg 2 / STi uppipe / Crucial Racing downpipe
    Stromung 2.5" catless centerpipe / Scooby Sport New Age centre pipe & backbox

  5. #4
    Registered User
    Join Date
    Mar 2010
    Posts
    2
    You guys rule I'll try it today.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •