engine management light on dash
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on engine management light on dash within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; can anyone help me iv just fitted an induction kit to my 2001 wrx and now the engine management light ...

  1. #1
    Registered User
    Join Date
    Mar 2010
    Posts
    1

    engine management light on dash

    can anyone help me
    iv just fitted an induction kit to my 2001 wrx and now the engine management light is staying on someone has told me tht the fuel pressure needs adjusting how do i do this email me at zxc898@aol.com
    Last edited by bilbym; 03-13-2010 at 10:36 AM. Reason: missed off email

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User fire_cky's Avatar
    Join Date
    Jul 2007
    Location
    San Francisco
    Posts
    815
    i assume by induction you mean an intake of some sort. check to make sure the mass air flow sensor is in the proper position, because if it's not, it'll throw a check engine light.
    '07 wrx wagon:
    Cobb catback, cobb short ram with intake box, turbosmart small recirc valve, yellow tinted fogs.

    little bit older and a little bit more jaded.

  4. #3
    Registered User mudferret's Avatar
    Join Date
    Aug 2009
    Location
    Canada/Ethiopia/Madagascar
    Posts
    1,979
    As mentioned above, could be a result of the MAF not being happy with the new intake, or perhaps it wasn't seated into the new intake tube properly.

    Always best to get a code read however, many places do it for free depending on where you are and it can potentially save a lot of guess work.
    ...Rob.
    MMVI WRX - VF43 Airboy Tuned @ 3500'

  5. #4
    Registered User fire_cky's Avatar
    Join Date
    Jul 2007
    Location
    San Francisco
    Posts
    815
    what happened to me when i installed my short ram was that i had the MAF tube rotated a little too far over, so the MAF sensor was not in the original position. easy fix, for me at least.
    '07 wrx wagon:
    Cobb catback, cobb short ram with intake box, turbosmart small recirc valve, yellow tinted fogs.

    little bit older and a little bit more jaded.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •