06 STi Turbo Failure/Oil pressure drop
Page 1 of 3 123 LastLast
Results 1 to 15 of 38

This is a discussion on 06 STi Turbo Failure/Oil pressure drop within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Having a problem with troubleshooting on my 06 STi. did an oil change approx 500 miles ago, and while driving ...

  1. #1
    Registered User STi-Guy85's Avatar
    Join Date
    Mar 2007
    Location
    Savannah GA
    Posts
    170

    Exclamation 06 STi Turbo Failure/Oil pressure drop

    Having a problem with troubleshooting on my 06 STi. did an oil change approx 500 miles ago, and while driving a few days ago, my oil light came on in the car.... drove 3 or 4 more miles so i could park it in a safe place, and when i crunk it back up, turbo sounded like it had a million pieces of broken metal inside. Kind of guessed it was an oil pump failure that caused the low oil pressure, which resulted in the turbo failure. Tonight i removed the turbo to discover about 1/4 inch of shaft play, and a few bearings rolling around inside. Checked my oil filter for brassy or copper colored metal shavings, to ensure no engine damage was caused. Also removed old oil pump tonight, but after messing around with it for a few minutes, it seems to be in the exact working condition as the newly purchased pump.... My question is, can a turbo failure cause a sudden oil pressure drop? And if not, does anyone have any ideas where i should start looking for my oil issue? Tomorrow i am lifting the motor in order to remove the oil pan and check the oil pickup line to ensure it is in good working condition. I could really use some help on this one...my car is in a million pieces! Ready to get this resolved... thanks for the help

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Medford, Oregon
    Posts
    25,518
    I Support ClubWRX
    UM.. Its an 06 how many miles do you have? Do you realize that your car has a 5 year 60,000 mile powertrain warranty? It depends how much oil was blowing out your tailpipe and how much was blowing through your intake system to show a pressure drop. I guess it could happen just because they are under pressure as well. Sounds to me like you simply lost your turbo. Id replace the oil pump since you already bought it.


    Lead Wrench @ WTF Tuning, LLC

  4. #3
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Did you ever replace the little screen filter in the oil feed line to the turbo? If not, that's probably your problem.

    With the oil light on though, you're lucky you didn't do any major engine damage. Replace the oil pump while you're there though, don't re-use it.

    edit: details on AVCS line filter. Turbo oil-feed / AVCS line replacement - IWSTI.com: Subaru WRX STI Forums
    Last edited by xxxxxxxAnub1s; 03-06-2010 at 10:32 PM.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  5. #4
    Registered User STi-Guy85's Avatar
    Join Date
    Mar 2007
    Location
    Savannah GA
    Posts
    170
    yea the car has fairly high mileage for an 06, like 80k or so.... and i am going to go ahead and put the new oil pump on. Also have a new timing belt, may as well take care of that as well... My main concern is that if I dont locate the oil issue (if there even is one) that i will just go through another turbo.... I will check out that oil feed line to the turbo tomorrow when i get back to the car... i had actually heard a while back about some issues with the screens in the avcs and what not, so i took the banjo bolts out of my avcs to discover that there weren't any screens at all. I dont know man, just trying to do this the right way... but back to the question at hand, can turbo failure cause a massive pressure drop...yes or no?

  6. #5
    Moderator T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Medford, Oregon
    Posts
    25,518
    I Support ClubWRX
    Are we talking pressure drop as in your light came on or you have an oil pressure gauge?


    Lead Wrench @ WTF Tuning, LLC

  7. #6
    Registered User STi-Guy85's Avatar
    Join Date
    Mar 2007
    Location
    Savannah GA
    Posts
    170
    light came on.... called my tuner about it though, and he said that light comes on at around 2.8lbs of oil pressure, which is super low.... oil pressure guage will arrive on tuesday...not going through this again once i sort it out

  8. #7
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by STi-Guy85 View Post
    light came on.... called my tuner about it though, and he said that light comes on at around 2.8lbs of oil pressure, which is super low.... oil pressure guage will arrive on tuesday...not going through this again once i sort it out
    Yes it is, low enough to destroy an engine rather quickly. I've never had it happen to me, but I've prepared myself to shut off the engine ASAP when that light comes on. It's set so low that as soon as it comes on, your engine might already be dead anyways.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  9. #8
    Registered User STi-Guy85's Avatar
    Join Date
    Mar 2007
    Location
    Savannah GA
    Posts
    170
    yea thats what he told me...said 2.8 is low enough to spin a bearing even at idle. I am amazed that i didn't do any damage...but so far, everything seems good, as far as engine damage anyways.

  10. #9
    Registered User STi-Guy85's Avatar
    Join Date
    Mar 2007
    Location
    Savannah GA
    Posts
    170
    still though, the fact that the light ever came on disturbs me... and i dont really know where to start looking for an issue, which is why i was trying to find out about turbo failure causing that light.

  11. #10
    Moderator T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Medford, Oregon
    Posts
    25,518
    I Support ClubWRX
    Yes the turbo failure can cause the light, I would replace turbo, change oil pump timing belt water pump blah blah and fix the screens issue.


    Lead Wrench @ WTF Tuning, LLC

  12. #11
    Registered User STi-Guy85's Avatar
    Join Date
    Mar 2007
    Location
    Savannah GA
    Posts
    170
    Quote Originally Posted by LPPTundWRX View Post
    Yes the turbo failure can cause the light, I would replace turbo, change oil pump timing belt water pump blah blah and fix the screens issue.
    Thanks so much dude... I have all of those parts already, so i'm glad to see that I'm moving in the right direction.... but..... if i replace/take care of those things and still have the issue, what would my next step be?

  13. #12
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by STi-Guy85 View Post
    yea the car has fairly high mileage for an 06, like 80k or so.... and i am going to go ahead and put the new oil pump on. Also have a new timing belt, may as well take care of that as well... My main concern is that if I dont locate the oil issue (if there even is one) that i will just go through another turbo.... I will check out that oil feed line to the turbo tomorrow when i get back to the car... i had actually heard a while back about some issues with the screens in the avcs and what not, so i took the banjo bolts out of my avcs to discover that there weren't any screens at all. I dont know man, just trying to do this the right way... but back to the question at hand, can turbo failure cause a massive pressure drop...yes or no?
    I wouldn't think so. The light is triggered from a switch in an oil galley on the block if I remember correctly. So you're engine pressure was low enough to set off the light. Main oil is different from the pressure at the turbo. I don't think there's enough oil going through the turbo to influence the engine oil that much if something blocks it off there, but I could be wrong.

    edit: Apparently I'm wrong lol
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  14. #13
    Registered User STi-Guy85's Avatar
    Join Date
    Mar 2007
    Location
    Savannah GA
    Posts
    170
    also one more thing that i failed to mention.... when i took the intercooler off tonight, i noticed a substantial amount of oil where the intercooler and intake meet.... result of turbo failure as well?

  15. #14
    Moderator T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Medford, Oregon
    Posts
    25,518
    I Support ClubWRX
    Quote Originally Posted by STi-Guy85 View Post
    also one more thing that i failed to mention.... when i took the intercooler off tonight, i noticed a substantial amount of oil where the intercooler and intake meet.... result of turbo failure as well?
    Im willing to bet your engine oil is very low. Check your plugs see if you have any melt downs, Im wondering if your number 4 cyl took a ****.


    Lead Wrench @ WTF Tuning, LLC

  16. #15
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by STi-Guy85 View Post
    also one more thing that i failed to mention.... when i took the intercooler off tonight, i noticed a substantial amount of oil where the intercooler and intake meet.... result of turbo failure as well?
    Some oil is expected, however, if it's excessive it's possible that excess oil snuck into the compressor housing if a seal was blown when the turbo failed.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •