06 STi Turbo Failure/Oil pressure drop - Page 3
Page 3 of 3 FirstFirst 123
Results 31 to 38 of 38

This is a discussion on 06 STi Turbo Failure/Oil pressure drop within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Originally Posted by STi-Guy85 yea i have already taken the pump off, waiting until tomorrow to put the new one ...

  1. #31
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by STi-Guy85 View Post
    yea i have already taken the pump off, waiting until tomorrow to put the new one on....i'm really curious about the oil pickup line that actually brings oil from the pan to the pump.... i want to see what the screen in there looks like, or if there is any sort of tear or kink or whatever in the hose.
    Cool, here is the bulletin from Subaru on the filter. Includes a picture so you know what to look for:

    http://store.forcedperformance.net/m.../02-103-07.pdf
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #32
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by STi-Guy85 View Post
    i hope you are right dude...my biggest fear is having an issue that i cant find, or dont know where its coming from... i hate trial and error, especially on such an expensive toy.. i want to know where i'm going when i start pulling that car apart... it took a solid 4 hours to get the turbo and oil pump out.
    I know exactly where you're coming from here. I had an 02 WRX before my 06 and I sunk about 3 grand into it diagnosing a misfire problem. At least your narrows things down a little bit lol. Hope you can get this taken care of soon bro. Keep us updated I'd like to know what's going on.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  4. #33
    Registered User STi-Guy85's Avatar
    Join Date
    Mar 2007
    Location
    Savannah GA
    Posts
    170
    yea i saved that to my computer a couple of days ago when this all started. so you think replacing the pump will get everything back in line?

  5. #34
    Registered User STi-Guy85's Avatar
    Join Date
    Mar 2007
    Location
    Savannah GA
    Posts
    170
    Quote Originally Posted by Anub1s View Post
    I know exactly where you're coming from here. I had an 02 WRX before my 06 and I sunk about 3 grand into it diagnosing a misfire problem. At least your narrows things down a little bit lol. Hope you can get this taken care of soon bro. Keep us updated I'd like to know what's going on.
    I will keep you guys updated, thanks for your help bro.

  6. #35
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by STi-Guy85 View Post
    yea i saved that to my computer a couple of days ago when this all started. so you think replacing the pump will get everything back in line?
    Except for the turbo, yeah I think so. But, can't really guarantee that or anything, ya know? But it's a good place to start.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  7. #36
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by STi-Guy85 View Post
    I will keep you guys updated, thanks for your help bro.
    Any time, good luck mang.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  8. #37
    Moderator T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Medford, Oregon
    Posts
    25,518
    I Support ClubWRX
    only use factory filters oil filters


    Lead Wrench @ WTF Tuning, LLC

  9. #38
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by LPPTundWRX View Post
    only use factory filters oil filters
    A mantra to live by.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •