06 STi Turbo Failure/Oil pressure drop - Page 2
+ Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 38

This is a discussion on 06 STi Turbo Failure/Oil pressure drop within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Originally Posted by Anub1s Some oil is expected, however, if it's excessive it's possible that excess oil snuck into the ...

  1. #16
    Moderator T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Medford, Oregon
    Posts
    25,522
    I Support ClubWRX
    Quote Originally Posted by Anub1s View Post
    Some oil is expected, however, if it's excessive it's possible that excess oil snuck into the compressor housing if a seal was blown when the turbo failed.
    Thats why Im thinking his light came on, so much oil blowing thru the system and out the tailpipe as well.


    Lead Wrench @ WTF Tuning, LLC

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by LPPTundWRX View Post
    Im willing to bet your engine oil is very low. Check your plugs see if you have any melt downs, Im wondering if your number 4 cyl took a ****.
    This is something to look at as well. Do a compression check as well just in case.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  4. #18
    Registered User STi-Guy85's Avatar
    Join Date
    Mar 2007
    Location
    Savannah GA
    Posts
    170
    Quote Originally Posted by LPPTundWRX View Post
    Im willing to bet your engine oil is very low. Check your plugs see if you have any melt downs, Im wondering if your number 4 cyl took a ****.
    Until i drained the oil tonight, i was right at the fill line... and i just changed plugs 2 mondays ago! Went to ngk iridium one step colder... i didnt have any oil problems until i went to full syn oil...this is only the 2nd oil change using it, and here i am... the wierd thing is, that if the car runs right now, it idles like a champ, sounds just as good as brand new.

  5. #19
    Moderator T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Medford, Oregon
    Posts
    25,522
    I Support ClubWRX
    when my #4 went in my car it had a funny noise.. Seriously that is it, no power change no nothing.. I just caught it at the very beginning.


    Lead Wrench @ WTF Tuning, LLC

  6. #20
    Registered User STi-Guy85's Avatar
    Join Date
    Mar 2007
    Location
    Savannah GA
    Posts
    170
    thats what i'm saying though, no funny noises at all...everything sounds perfectly normal, with the exception of the turbo, which is no longer on the car

  7. #21
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by LPPTundWRX View Post
    Thats why Im thinking his light came on, so much oil blowing thru the system and out the tailpipe as well.
    True. If the turbo was eating so much oil and blowing it back into the engine it would deplete it to the point that the pressure was low. I was thinking more along the lines of the oil flow being restricted or blocked when the question was posed about turbo failure directly causing the low pressure, I get it now
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  8. #22
    Registered User STi-Guy85's Avatar
    Join Date
    Mar 2007
    Location
    Savannah GA
    Posts
    170
    Quote Originally Posted by Anub1s View Post
    True. If the turbo was eating so much oil and blowing it back into the engine it would deplete it to the point that the pressure was low. I was thinking more along the lines of the oil flow being restricted or blocked when the question was posed about turbo failure directly causing the low pressure, I get it now
    but the thing about that is there isn't excess oil coming from the tailpipe or anything... like i said, i drained 5 quarts of oil from the car tonight, i wasn't losing any from anywhere that i can see. Still had the full load of oil.

  9. #23
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by STi-Guy85 View Post
    thats what i'm saying though, no funny noises at all...everything sounds perfectly normal, with the exception of the turbo, which is no longer on the car
    Sounds CAN be decieving though. It's best to check everything possible at this point.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  10. #24
    Registered User STi-Guy85's Avatar
    Join Date
    Mar 2007
    Location
    Savannah GA
    Posts
    170
    ok will do a compression check asap.

  11. #25
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by STi-Guy85 View Post
    but the thing about that is there isn't excess oil coming from the tailpipe or anything... like i said, i drained 5 quarts of oil from the car tonight, i wasn't losing any from anywhere that i can see. Still had the full load of oil.
    Eesh, your car just doesn't want to be diagnosed does it? lol. When you started it up again was the oil light off?
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  12. #26
    Registered User STi-Guy85's Avatar
    Join Date
    Mar 2007
    Location
    Savannah GA
    Posts
    170
    no, stays on continuously. when it first came on, it was just at idle, and around 2k rpm it would go off, which is what initially made me think about an oil pump, but now its just on all the time.

  13. #27
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Quote Originally Posted by STi-Guy85 View Post
    no, stays on continuously. when it first came on, it was just at idle, and around 2k rpm it would go off, which is what initially made me think about an oil pump, but now its just on all the time.
    Yeah, change that ***** out, add oil and see if it fixes it. It's not common for an oil pressure switch to go bad, so I'm pretty much certain there's a mechanical reason for this.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  14. #28
    Registered User STi-Guy85's Avatar
    Join Date
    Mar 2007
    Location
    Savannah GA
    Posts
    170
    yea i have already taken the pump off, waiting until tomorrow to put the new one on....i'm really curious about the oil pickup line that actually brings oil from the pan to the pump.... i want to see what the screen in there looks like, or if there is any sort of tear or kink or whatever in the hose.

  15. #29
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    In fact, my money is on the oil pump going bad which caused the pressure at the turbo to go low which caused the bearing failure. So it's likely not the turbo causing the other issues, it's the other issues causing the turbo issue.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  16. #30
    Registered User STi-Guy85's Avatar
    Join Date
    Mar 2007
    Location
    Savannah GA
    Posts
    170
    i hope you are right dude...my biggest fear is having an issue that i cant find, or dont know where its coming from... i hate trial and error, especially on such an expensive toy.. i want to know where i'm going when i start pulling that car apart... it took a solid 4 hours to get the turbo and oil pump out.

+ Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •