Weird Turbo Noise / Overboosting or not spooling
Results 1 to 2 of 2

This is a discussion on Weird Turbo Noise / Overboosting or not spooling within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey guys, I get home from school start the car and take it out for a spin. Turbo starts making ...

  1. #1
    Registered User br3ez's Avatar
    Join Date
    Apr 2004
    Location
    Bergen County, NJ / NEU, Boston
    Posts
    2,139

    Weird Turbo Noise / Overboosting or not spooling

    Hey guys,

    I get home from school start the car and take it out for a spin. Turbo starts making some new noises and boost is all over the place. I overboosted to about 1.6bar and sometimes it doesnt even spool. Im thinking the turbo is going to blow soon or the wastegate is screwed up. Let me know what you think, hopefully i can get to a shop sometime this week.

    Jeff
    2005 WRX
    UTEC Stage 2 (Catless)

    250.02 WHP
    249.27 WTQ
    Junior Tuned

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,996
    I Support ClubWRX
    Not alot of info. Run a scanner on it and check for codes or pending codes. My guess is you are severly over boosting,knocking and IAM is possibly dropping and lowering boost to wategate. Unless you have a way of posting a log or describing the problem with more detail getting it to a shop is your best bet.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •