Brake Lights but no Tail Lights... Help!!!
Results 1 to 6 of 6

This is a discussion on Brake Lights but no Tail Lights... Help!!! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hello, I recently discovered I had a brake light out so I bought the replacement bulb at Schucks. According to ...

  1. #1
    Registered User
    Join Date
    Nov 2004
    Posts
    6

    Unhappy Brake Lights but no Tail Lights... Help!!!

    Hello,
    I recently discovered I had a brake light out so I bought the replacement bulb at Schucks.

    According to my manual the correct bulb is the model number 7440 for brake lights.

    So I bought that and installed them. I did have one hang up when replacing them where the bulbs were REALLY difficult to install into the light sockets.

    I looked at the bulbs and they have a slightly bigger round notch at the bottom then the stock ones I had did. With a lot of time and strength I got them in. Tested them and found that the brake lights work.

    Now I was told by another dirver that I do have brake lights but no running lights. I thought to myself maybe another pair of bulbs went out. Looked up in my manual and it says they are my brake/tail lights are the same bulb.


    So am I missing something here?

    Are the bulbs really suppose to be that difficult to replace?

    I feel very stupid at the moment....



    Thanks!

    C/N: Changed brake lights, now don't have working tail lights.

    Car: 2005 Subaru Impreza WRX Wagon

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Are you 100% sure they are the proper bulbs? They should be dual filament bulbs I believe if you installed single filament bulbs something like this could happen....

  4. #3
    Moderator T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Medford, Oregon
    Posts
    25,515
    I Support ClubWRX
    Sounds like you bought the wrong bulbs. Time to go get the right ones and reinstall.


    Lead Wrench @ WTF Tuning, LLC

  5. #4
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,998
    I Support ClubWRX
    Are you sure you used the appropriate bulb in the appropriate socket?
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  6. #5
    Registered User
    Join Date
    Nov 2004
    Posts
    6
    Yeah I concluded that the user maual is a liar.

    It stated for the wagon the brake lights are 7440.
    When they clearly are suppose to be 7443 with the dual filament.

    Oh well.
    Lesson learned.
    I will be installing the correct ones tonight me thinks....

    Thanks for the help guys!
    =)

  7. #6
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Quote Originally Posted by Brisky View Post
    Yeah I concluded that the user maual is a liar.

    It stated for the wagon the brake lights are 7440.
    When they clearly are suppose to be 7443 with the dual filament.

    Oh well.
    Lesson learned.
    I will be installing the correct ones tonight me thinks....

    Thanks for the help guys!
    =)
    No problem bro.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •