1998 impreza WR, electric problems, wont start!!!!!
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on 1998 impreza WR, electric problems, wont start!!!!! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Yesterday as my girlfriend was driving home in the snow the heater fan stopped working, the lights died and as ...

  1. #1
    Registered User
    Join Date
    Feb 2010
    Posts
    2

    1998 impreza WR, electric problems, wont start!!!!!

    Yesterday as my girlfriend was driving home in the snow the heater fan stopped working, the lights died and as she was stuck in a tail back she turned the engine off. She had the window down half way so tryed to wind it back up but it wouldnt, she tried to restart the car but its totaly dead. The only things that work are the wipers, some dashlights the iterior light, clock and radio, everything else is dead. The alarm fob light works though the alarm doesnt respond, at first i though the immobiliser was the problem but if this had died all the other electrics would work i would have thought but nothing apart from what ive said works. Ive had to have the car towed back in the snow as we couldnt get the window up or lock the thing!!!

    Has this ever happened to anyone else or can anyone give me any information as to where to start to look to get this fixed? all the fuses are fine and the simple things like that but im lost on where to look so any help would be great.

    Cheers

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2

    Admin - Scooby Hooligan

    Weasel 555's Avatar
    Join Date
    Jul 2002
    Location
    UK,NY,AK,FL
    Posts
    23,158
    I Support ClubWRX
    hi and welcome,
    sounds to me like the alternator wasnt charging the battery properly, have you checked the belts to see if they are tight

    also sent you a pm(private message)
    ScoobyDMC #000,HawkEyeAlliance#000,Blobeye Syndicate #000, SQC-NY #009, "Dragon Slayer"
    "All We'll Drive"

    I <3 boobies: rallyarmor/keepabreast/mud flaps limited edition

  4. #3
    Registered User
    Join Date
    Feb 2010
    Posts
    2
    To be honest the belts are a little lose but nothing to major, she did try and have a jump start yesterday but that made no difference. anything that does work work well and at full power but everything else is dead and the batt is showing plenty of charge on the test meter

  5. #4

    Admin - Scooby Hooligan

    Weasel 555's Avatar
    Join Date
    Jul 2002
    Location
    UK,NY,AK,FL
    Posts
    23,158
    I Support ClubWRX
    ok mate, can you swap out the battery from another car and try again and see what happens.
    ScoobyDMC #000,HawkEyeAlliance#000,Blobeye Syndicate #000, SQC-NY #009, "Dragon Slayer"
    "All We'll Drive"

    I <3 boobies: rallyarmor/keepabreast/mud flaps limited edition

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •