Cel - p0121
+ Reply to Thread
Results 1 to 2 of 2

This is a discussion on Cel - p0121 within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; 2004 WRX, still stock Driving down interstate with cruise control, speed up a bit to get over & next thing ...

  1. #1
    Registered User da1tank's Avatar
    Join Date
    Feb 2010
    Location
    Newport News, VA
    Posts
    9

    Cel - p0121

    2004 WRX, still stock

    Driving down interstate with cruise control, speed up a bit to get over & next thing I know CEL came on.

    Pulled over & stopped, nothing seemed out of ordinary with the car, started up and made it to my cousin's house. This morning cranked the car, CEL still on...so I shut off when back got ready, then cranked again to warm up the engine a bit before leaving & CEL was off. Went to Autozone & the code that popped up when he hooked it up was P0121. So should I think about replacing the TPS or just cleaning the connection?

    Do you think throttle may have gotten a little stuck from using CC? The light is off & car seems to be running fine, just wondering any thoughts why it came on or if I should be looking forward to a quick repair in the future.

    Thanks

    **Edit** On the 2nd part of my trip, the light came back on again, hooked it up at Advance and code P0122 which still deals with TPS sensor popped up. ~125,600? miles are on the vehicle. Right now can't check much of anything due to snow :/ **Edit**
    Last edited by da1tank; 02-13-2010 at 12:33 AM.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Quote Originally Posted by da1tank View Post
    2004 WRX, still stock

    Driving down interstate with cruise control, speed up a bit to get over & next thing I know CEL came on.

    Pulled over & stopped, nothing seemed out of ordinary with the car, started up and made it to my cousin's house. This morning cranked the car, CEL still on...so I shut off when back got ready, then cranked again to warm up the engine a bit before leaving & CEL was off. Went to Autozone & the code that popped up when he hooked it up was P0121. So should I think about replacing the TPS or just cleaning the connection?

    Do you think throttle may have gotten a little stuck from using CC? The light is off & car seems to be running fine, just wondering any thoughts why it came on or if I should be looking forward to a quick repair in the future.

    Thanks
    How many miles are on the vehicle? Do you have the cruise control cable clip installed ( there was a campaign for this year still I believe...Ive seen a couple weird things happen from not having that installed....Did you take a look at the throttle cable and cruise cable do they look ok not jammed or corroded or caught on anything? Feel the throttle on the throttle body itself with your hand does it feel like it sticks at all? I will say Subarus don't generally have problems with the TPS sensors with the exception of the early EZ30 Outbacks...If you have the means I would pop a decent scanner in there and you can see if the TPS is working properly (throttle opening angle) if you view the data selection ( I have done this on Subarus selectmonitor before...Im sure there are other scan tools out there where this can be done...)....

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •