turbo timer help!
Results 1 to 10 of 10

This is a discussion on turbo timer help! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; hey guys im new the the wrx scene i have had other turbo cars. but i dont know nething about ...

  1. #1
    Registered User
    Join Date
    Jan 2010
    Posts
    13

    turbo timer help!

    hey guys im new the the wrx scene i have had other turbo cars. but i dont know nething about this stuff i usually keep it stock but, i got an 04 wrx there has been a few things done to it. im pretty sure it has been wired for a turbo timer. there is 2 plugs under the dash a white one and a black one i think the black one is the stock diagnos port... there is also some kind of plug under the clock. im trying to figure out what they are for. the piece by the cup holder is out. and i looked at the cpu and wires have been spliced into unfortunatly. and the cpu itsself has flashed and a date on it. any info would help me out alot thanks guys! ill post pics of plugs soon

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Administrator RayfieldsWRX's Avatar
    Join Date
    Oct 2002
    Location
    The Old Folks Home
    Posts
    46,940
    I Support ClubWRX
    Welcome to the Club!

    Your WRX does not actually require a turbo timer. The TD04 turbocharger in your car (assuming it's the OEM turbo) is oil and water cooled, meaning it's not subject to the same kinds of issues that some earlier turbo cars had if you cut them off hot.

    A lot of threads have been written about this; feel free to search around if you need more info!
    --Ray
    Grandfather of the Bugeye Mafia
    2013 Subaru BRZ Limited
    2002 Subaru WRX Bugeyebrid Wagon

  4. #3
    Registered User
    Join Date
    Jan 2010
    Posts
    13
    i think i have over heated it and wore it out sounds like the turbine is hitting the walls and it has choppy boost it high rpms. it workd perfectly when i got it and didnt make a sound it looks like a large turbo idk the size or specs but pretty sure ive smoked it. you know how to rebuild the turbo i havent done that before... thanks for you reply!!

  5. #4
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    Would it be possible for you to post pictures of your car?
    If so please take pictures of the turbo, engine bay, connectors, and the uppipe/downpipe (exhaust peaces connected to the turbo).

    Hopefully we can help you fix it up

  6. #5
    Registered User
    Join Date
    Jan 2010
    Posts
    13
    i uploaded some pics you can see there are things done incl. a 6sp sti trans swap, that works beautifully! sti carpet and intercooler,

    in the one pic you can see the diagnostic port the mysterious plug and a hose for an aftermarket boost gauge.

    theres a pic of the other mysterious plug up under the clock. idk what either plugs are...

    i didnt take a pic but it has the dccd switch not hooked up havent looked for the wire under the carpet yet.

    and the turbo not much info u can get off it in those pics but best i can do out there in the 16 degree weather lol

    yeah man i will get in depth pics of engine bay tom afternoon thanks!! ya i just want it running strong again.
    Attached Thumbnails Attached Thumbnails DSCI0086.jpg   DSCI0089.jpg   DSCI0092.jpg   DSCI0095.jpg   DSCI0094.jpg  

    DSCI0090.jpg  
    Last edited by domestics-only; 02-12-2010 at 11:41 AM.

  7. #6
    Administrator RayfieldsWRX's Avatar
    Join Date
    Oct 2002
    Location
    The Old Folks Home
    Posts
    46,940
    I Support ClubWRX
    Hmm, one observation is that your turbo heat sheild is missing, assuming you didn't remove it for pics. The downpipe appears to be the stocker, so it looks like someone removed some mods and returned the car to "stock" before selling it.
    --Ray
    Grandfather of the Bugeye Mafia
    2013 Subaru BRZ Limited
    2002 Subaru WRX Bugeyebrid Wagon

  8. #7
    Registered User Bahamabob's Avatar
    Join Date
    May 2005
    Location
    Bridgewater, Ma
    Posts
    154
    I Support ClubWRX
    black plug= obd2 port
    plug under clock = clock wiring /power
    plug under dash ? maybe audio system plug
    Judging by the rust I would think that car has been water damaged/submerged

  9. #8
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    Bahamabob, I would say that rust doesn't look too bad. My Grand Am's under-dash bit's looked worse than that after 6 years in the Seattle area.
    Then again, D-O's Impreza does have the blue STI carpet, so it's not unlikely that the car needed a new carpet.

    domestics-only, 6-speed, NICE!
    What area do you live in? Maybe we can find you a tuner close by that can have a better look, and possibly tune the ECU for the cars current mods.

  10. #9
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Eesh, that car does not look happily taken care of, unfortunately.

    Like said above, the black plug is your OBD-2 port, that shouldn't be plugged into anything, it's used for diagnostic services and flashing/logging.

    Under the clock is the regular white plug for the clock, and those purple things are tie in connectors, looks like someone used those wires for power and ground, likely for a guage setup which is probably why there is some wierd wiring things going on with the ECU as well.

    The white connector under the dash looks like it goes to something that was in the vehicle or wired for an option, though I'm not exactly sure what.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  11. #10
    Registered User
    Join Date
    Jan 2010
    Posts
    13
    he changed all kinds of stuff. i know its not the cleanest but its not as bad as some cars ive had and it is perfect on the rest of the car interior exterior. i got a really good deal on it tho. no thats normal rust stuff. my truck and wifes car has the same truck has it even worse.
    i did have a question bout the clock tho its not the factory plug or i got the wrong clock

    jeremy96gase: yeah i love the six speed i made sure it was installed right when i got it but i would deff do a swap if it didnt have it well worth the work!
    I live down in beavercreek ohio.. not many subarus running around here at all.
    Last edited by domestics-only; 02-13-2010 at 09:25 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •