Wiper gremlin
Results 1 to 3 of 3

This is a discussion on Wiper gremlin within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I'm hoping one of you guys has some ideas, because I'm lost. My '02 WRX Sport Wagon that I've had ...

  1. #1
    Registered User
    Join Date
    Jan 2006
    Location
    Bakersfield, CA
    Posts
    3

    Wiper gremlin

    I'm hoping one of you guys has some ideas, because I'm lost. My '02 WRX Sport Wagon that I've had since new now has 62,000 miles on it, and recently has developed a mind of it's own with the windshield wipers.

    The 'park' feature has quit working altogether, the intermittent timer works when it wants to, and if you pull the lever to get a mist swipe, the wipers will make 1 1/2 sweeps and stop in the middle of the windshield. In order to get the wipers back down to the bottom of the windshield, you have to pulse the lever manually. It's nothing earth shattering, but it sure is an annoyance.

    The rear wiper seems to be working normally, by the way.

    Has any of you had a similar problem and have an idea where to start?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User mudferret's Avatar
    Join Date
    Aug 2009
    Location
    Canada/Ethiopia/Madagascar
    Posts
    1,979
    Sounds like a bad wiper park switch. I'm not sure how serviceable the WRX wiper motors are, or whether it's easier to just get a new motor.

    Could also be the switch on the wiper stock.
    ...Rob.
    MMVI WRX - VF43 Airboy Tuned @ 3500'

  4. #3
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Personally a shot from the hip I would say the contacts in the switch are dirty or the switch is on its way out...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •