Whirring / Whining noise related to turbo
Results 1 to 3 of 3

This is a discussion on Whirring / Whining noise related to turbo within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; This past weekend a buddy and I were working on my car trying to address what seems like the fairly ...

  1. #1
    Registered User
    Join Date
    Nov 2008
    Location
    Bellingham, WA
    Posts
    11

    Question Whirring / Whining noise related to turbo

    This past weekend a buddy and I were working on my car trying to address what seems like the fairly common problem of a gas smell. After sniffing around for a minute, we found a hose underneath the intercooler that was not properly connected to the engine. So, we removed the intercooler, re-connected the hose, and hooked the intercooler back up. Everything seemed fine until a few days later, I was driving up to the mountain when I noticed a whine coming from the engine. It definitely seemed related to the turbo -- the noise started as the turbo pressure gauge approached 0, and became higher volume and pitch the higher the pressure. While the noise seems to be related to the turbo, it sounds like it's coming from the other side of the engine compartment.

    Any ideas of what I should be looking for?

    -- '02 wrx wagon

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,713
    I Support ClubWRX
    The leak you may have generated when r/r the IC.
    WRX Info Links, Courtesy TheJ
    Man is a brute.... If you're cruel to him, he respects and fears you. If you're kind to him, he plucks your eyes out. Alexis Zorbas
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User
    Join Date
    Apr 2010
    Posts
    8
    I'm having the exact same issue after changing my up pipe. I thought I just didn't tighten the bolts enough, so I retightened everything on the up pipe and am still having the whining noise. It sounds like someone is sitting in my engine bay blowing on a New Year's Eve noise-maker anytime my boost spools up over 5 psi. I was starting to suspect the IC, but would love to know what exactly to look for.

    Any help would be GREATLY appreciated!

    Thanks!

    Aaron

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •