im a subaru noob help me subaru brothers !
Results 1 to 13 of 13

This is a discussion on im a subaru noob help me subaru brothers ! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; hey guys i just recently got a 05 STi and im kinda nooby about cars the mods it has is, ...

  1. #1
    Registered User ImpresserSti's Avatar
    Join Date
    Jan 2010
    Posts
    19

    im a subaru noob help me subaru brothers !

    hey guys i just recently got a 05 STi and im kinda nooby about cars

    the mods it has is, antilag enable wired to the foglight switch
    whiteline antisway bars
    upgraded fuel pump
    APS front mount

    well the other night i was driving and i flogged it around a corner then later down the road i saw smoke from the rear and turns out my rear right tyre blew out, i have the Semislick Potenzas, they are new just got them.

    and im wondering if anyones got ideas on why it blew out ? the tyre damage is really bad big holes in it, the road was clear and i didnt run over anything

    i have a stock clutch, everytime i launch it burns soo easily, is it time i get a new clutch ?

    + sometimes when i start my car i see white smoke comming from the back, whats this mean ? mate tells me its really bad got me worried

    and on start up my rpms idles at 1.5 and it goes up and down from 1.5 to 1k, why does it do that ?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Poohbear's Avatar
    Join Date
    Mar 2009
    Location
    Ohio
    Posts
    943
    RPMS moving that far could mean vacuum leak or some other leak in the car... The white smoke, that could be either moister burning off or it means you could have a coolant leak of some sort... Is the white smoke only at start up or is it constant?
    Your vehicle is an extension of your skill as a driver, not a substitute for it.

    Stink-Eye Mob Member #21
    08+ Gauge install DIY
    Turn off your seat belt chime

  4. #3
    Registered User ImpresserSti's Avatar
    Join Date
    Jan 2010
    Posts
    19
    Quote Originally Posted by Poohbear View Post
    RPMS moving that far could mean vacuum leak or some other leak in the car... The white smoke, that could be either moister burning off or it means you could have a coolant leak of some sort... Is the white smoke only at start up or is it constant?
    it is only at start up and it happens sometimes only, this is strange i just got a major service, wouldnt they notice these leaks

  5. #4
    Registered User Poohbear's Avatar
    Join Date
    Mar 2009
    Location
    Ohio
    Posts
    943
    What did you get with your service? If its only at start up your probably just burning off moister in the exhaust or could just be condensation at warm up depending on how cold it is outside. What do you mean it happens sometimes? Is it a thick white smoke or just more like steam/mist ish... If your burning coolant from say your throttle body it would be pretty thick..

    Check your coolant make sure isnt low... I have had some experience where coolant bubbles in the line cause idle issues...

    can also be this anti lag system you have set up... Those are usually pretty rough on turbos and exhaust.. You anti lag system may have also caused a leak elsewhere that makes the idle jump around... Those really shouldn't be put on DD cars

    I am assuming that the anti lag system you have set up is using retarded ignition for the combustion... From what iv read ignition can set as far off as 40 degrees... not exactly good... these systems cant just be put on any car there needs to modification for use... and generally its race only use since they are so rough on the turbo...
    Last edited by Poohbear; 01-17-2010 at 01:59 PM.
    Your vehicle is an extension of your skill as a driver, not a substitute for it.

    Stink-Eye Mob Member #21
    08+ Gauge install DIY
    Turn off your seat belt chime

  6. #5
    Registered User ImpresserSti's Avatar
    Join Date
    Jan 2010
    Posts
    19
    Quote Originally Posted by Poohbear View Post
    What did you get with your service? If its only at start up your probably just burning off moister in the exhaust or could just be condensation at warm up depending on how cold it is outside. What do you mean it happens sometimes? Is it a thick white smoke or just more like steam/mist ish... If your burning coolant from say your throttle body it would be pretty thick..

    Check your coolant make sure isnt low... I have had some experience where coolant bubbles in the line cause idle issues...

    can also be this anti lag system you have set up... Those are usually pretty rough on turbos and exhaust.. You anti lag system may have also caused a leak elsewhere that makes the idle jump around... Those really shouldn't be put on DD cars

    I am assuming that the anti lag system you have set up is using retarded ignition for the combustion... From what iv read ignition can set as far off as 40 degrees... not exactly good... these systems cant just be put on any car there needs to modification for use... and generally its race only use since they are so rough on the turbo...
    well with the antilag system, its wired to the foglight switch so its not active i can turn it off and on anytime. I rarely turn it on, i always keep it off.

    i got a full inspection, changed spark plugs, new oil, new brake fluid, new coolant, wheel allignment

  7. #6
    Registered User Poohbear's Avatar
    Join Date
    Mar 2009
    Location
    Ohio
    Posts
    943
    Well just because you can turn it off doesnt mean damage hasnt already been done.... Are you the one who installed it? I mean who knows what the previous owner did and how long he or she ran the system..

    Did the idle issue happen before the service? If not take the car back to the dealer and say "look my car didnt do this before. Whats the issue?"

    The coolant was changed out so there could be a bubble in the coolant line... Like i said before I have seen this cause idle fluctuations (not in a subaru in other cars though).
    Your vehicle is an extension of your skill as a driver, not a substitute for it.

    Stink-Eye Mob Member #21
    08+ Gauge install DIY
    Turn off your seat belt chime

  8. #7
    Registered User ImpresserSti's Avatar
    Join Date
    Jan 2010
    Posts
    19
    Quote Originally Posted by Poohbear View Post
    Well just because you can turn it off doesnt mean damage hasnt already been done.... Are you the one who installed it? I mean who knows what the previous owner did and how long he or she ran the system..

    Did the idle issue happen before the service? If not take the car back to the dealer and say "look my car didnt do this before. Whats the issue?"

    The coolant was changed out so there could be a bubble in the coolant line... Like i said before I have seen this cause idle fluctuations (not in a subaru in other cars though).
    true true. i think your right about the white smoke issue about the moister. the previous owner hardly drove the car it had only 16,000kms when i bought it so pretty new and yes the idle has always been like this since the day i bought it

  9. #8
    Registered User Poohbear's Avatar
    Join Date
    Mar 2009
    Location
    Ohio
    Posts
    943
    Sounds like it could be a vacuum leak to me then...
    Your vehicle is an extension of your skill as a driver, not a substitute for it.

    Stink-Eye Mob Member #21
    08+ Gauge install DIY
    Turn off your seat belt chime

  10. #9
    Luke Skywalker Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    20,643
    Any kind of EM?
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning
    "If I have 10 ice cubes and you have 11 giraffes, how many pancakes can fit on the roof? Purple, because aliens donít wear hats" -Ying

  11. #10
    Banned
    Join Date
    Dec 2003
    Location
    Dallas, TX / Sterling, VA
    Posts
    6,629
    I Support ClubWRX
    Were you the person who modded the car? I'm asking because some of the stuff on there is totally backwards considering what else you have.

    What does the white smoke smell like?

  12. #11
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,997
    I Support ClubWRX
    Quote Originally Posted by Mikie13 View Post
    Any kind of EM?
    +1 FMIC's can cause idle issues without tuning.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  13. #12
    Moderator T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Medford, Oregon
    Posts
    25,515
    I Support ClubWRX
    Quote Originally Posted by Donkey View Post
    +1 FMIC's can cause idle issues without tuning.
    This


    Lead Wrench @ WTF Tuning, LLC

  14. #13
    Luke Skywalker Mikie13's Avatar
    Join Date
    Oct 2006
    Location
    Palmyra, NJ
    Posts
    20,643
    Quote Originally Posted by LPPTundWRX View Post
    This
    That
    The Hawk-Eye Alliance #90|The Blobeye Syndicate #0|The Stink-Eye Mob #0|N.E.R.D. Founding Member & #3
    2012 Lightning Red WRX Sedan Stock...for now Soon to be OpenSource tuned by: Mattypants @ WTF Tuning
    "If I have 10 ice cubes and you have 11 giraffes, how many pancakes can fit on the roof? Purple, because aliens donít wear hats" -Ying

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •