Exhaust issue!
+ Reply to Thread
Results 1 to 9 of 9

This is a discussion on Exhaust issue! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; My check engine light has been on since winter began and my mechanic who is familiar with foreign cars said ...

  1. #1
    Registered User Stasharino's Avatar
    Join Date
    Jun 2009
    Location
    Buffalo, NY
    Posts
    52

    Exhaust issue!

    My check engine light has been on since winter began and my mechanic who is familiar with foreign cars said he's almost sure its my rear 02 sensor which is located in the cat. Anyways my exhasut is shooting out so much exhaust smoke due to the cold winter an I was wondering if its because of the bad 02 sensor or if theres another issue.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Poohbear's Avatar
    Join Date
    Mar 2009
    Location
    Ohio
    Posts
    943
    Whats the code that your car is throwing at you? Did your mechanic read the ecu? or did he just guess it was the o2 censor?

    if he didnt you can go to just about any auto parts stor and they will read your ECU for free... They will tell you the code and you can see what the issue is... If it is the 02 censor the ecu will let you know
    Your vehicle is an extension of your skill as a driver, not a substitute for it.

    Stink-Eye Mob Member #21
    08+ Gauge install DIY
    Turn off your seat belt chime

  4. #3
    Registered User pdrpowerofWRX's Avatar
    Join Date
    Aug 2002
    Location
    Springfield, OH.
    Posts
    1,294
    Are you totally stock?
    '05 CGM Subaru Impreza WRX Mods
    '02 WRB Subaru Impreza WRX (sold)
    '94 Subaru Legacy Wagon L (daily)
    '90 Toyota Supra Turbo

  5. #4
    Moderator T0rque's Avatar
    Join Date
    Dec 2004
    Location
    Medford, Oregon
    Posts
    25,522
    I Support ClubWRX
    You gotta post the code so we can help.


    Lead Wrench @ WTF Tuning, LLC

  6. #5
    Registered User Stasharino's Avatar
    Join Date
    Jun 2009
    Location
    Buffalo, NY
    Posts
    52
    P0031
    HO2S Bank 1 Sen 1
    Heater Circouit Low

    Thats what it read....

  7. #6
    Registered User Poohbear's Avatar
    Join Date
    Mar 2009
    Location
    Ohio
    Posts
    943
    That would be your o2 sensor... The o2 sensor in FRONT of you catalytic converter.
    Your vehicle is an extension of your skill as a driver, not a substitute for it.

    Stink-Eye Mob Member #21
    08+ Gauge install DIY
    Turn off your seat belt chime

  8. #7
    Registered User Stasharino's Avatar
    Join Date
    Jun 2009
    Location
    Buffalo, NY
    Posts
    52
    Thats what i thought now you probably know that the part is $175 but i was going to get a universal sensor an sotter it in.

  9. #8
    Registered User Poohbear's Avatar
    Join Date
    Mar 2009
    Location
    Ohio
    Posts
    943
    It may be faulty wiring.. You can check the resistance in the heater element of the sensor and see if its with in factory specs ( i dont know what that is but the dealer or someone on here should be able to tell you) ...

    Im not a huge fan of universals that solder in and do not use em... Im sure people have had great luck with em though...
    Your vehicle is an extension of your skill as a driver, not a substitute for it.

    Stink-Eye Mob Member #21
    08+ Gauge install DIY
    Turn off your seat belt chime

  10. #9
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Quote Originally Posted by Stasharino View Post
    Thats what i thought now you probably know that the part is $175 but i was going to get a universal sensor an sotter it in.
    I would definately not get a universal sensor...For some odd reason Subarus are extremely touchy when it comes to certain aftermarket parts such as axles, thermostats, o2 sensors...just to name a few...I have seen brand new aftermarket o2 sensors throw a code on Subarus...I would highly recommend you go OEM for this part....

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •