HIDS flicker
Results 1 to 7 of 7

This is a discussion on HIDS flicker within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I just installed h11 6000ks in my 2010 wrx and at first my right light flickered then stopped then the ...

  1. #1
    Registered User 2010wrxsedan's Avatar
    Join Date
    Nov 2009
    Location
    Maine
    Posts
    11

    HIDS flicker

    I just installed h11 6000ks in my 2010 wrx and at first my right light flickered then stopped then the left. Then i got everything snugged up and tight and it was gone. But after driving around for a while i noticed on the back of the cars in front of me there was a slight flicker here and there, but it doesnt effect the actual beam at a distance. Would a resister fix this problem or what, any advice?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Banned
    Join Date
    Dec 2003
    Location
    Dallas, TX / Sterling, VA
    Posts
    6,629
    I Support ClubWRX
    Is there proper grounding?

  4. #3
    Registered User GarrettKoonsman's Avatar
    Join Date
    Apr 2009
    Location
    CO
    Posts
    2,664
    are you using a relay to the battery? If not its possible your not getting enough power to them. Or like said before the ground could be bad. Any problems with your brights??
    2003 Midnight Black Pearl WRX Sedan
    200.7 AWHP Protuned Stage 2 at 5400ft above sea level
    Bugeye Mafia Member #225
    Mods
    Pics

  5. #4
    Registered User 2010wrxsedan's Avatar
    Join Date
    Nov 2009
    Location
    Maine
    Posts
    11
    Its a plug and play,bulb to ballasts, ballast to stock relay, im sure its a power issue with them only being 35w, not 55w maybe the computer is confused? i dont know!

  6. #5
    Registered User Poohbear's Avatar
    Join Date
    Mar 2009
    Location
    Ohio
    Posts
    943
    what kit did you get? is the flicker happening with bumps in the road? loose solder in the ballasts or just cheap bulbs? just a thought....
    Your vehicle is an extension of your skill as a driver, not a substitute for it.

    Stink-Eye Mob Member #21
    08+ Gauge install DIY
    Turn off your seat belt chime

  7. #6
    Registered User GarrettKoonsman's Avatar
    Join Date
    Apr 2009
    Location
    CO
    Posts
    2,664
    Quote Originally Posted by 2010wrxsedan View Post
    Its a plug and play,bulb to ballasts, ballast to stock relay, im sure its a power issue with them only being 35w, not 55w maybe the computer is confused? i dont know!
    Run a relay to the battery. Should get rid of your power problem, except sometimes it messes with your brights
    2003 Midnight Black Pearl WRX Sedan
    200.7 AWHP Protuned Stage 2 at 5400ft above sea level
    Bugeye Mafia Member #225
    Mods
    Pics

  8. #7
    Registered User Bullit's Avatar
    Join Date
    Sep 2009
    Location
    OXNARD
    Posts
    88
    Same thing happened to my o2 wrx my left headlight would flicker, then once i start driving it would stay on but once i stopED an a redlight they would both start to flicker again. i went to a shop an the said it might be the relay or the ballast. i replaced the relays an still flickered so i just went an bought a digital hid kit which does not require any relays. I pluged them in an nomore flickering

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •