EJ20 leaking coolant from valve cover
Results 1 to 4 of 4

This is a discussion on EJ20 leaking coolant from valve cover within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I have an 02 WRX wagon as a DD with 170K on it. This was very well maintained and runs ...

  1. #1
    Registered User BlueHeavenWRX's Avatar
    Join Date
    Oct 2005
    Location
    Philly, Schwenksville
    Posts
    81

    EJ20 leaking coolant from valve cover

    I have an 02 WRX wagon as a DD with 170K on it.

    This was very well maintained and runs GREAT.

    Current mods are full catless wrapped TBE.

    SPT intake with K&N short ram

    Reflashed to Cobb Stg. 2

    Today I discovered a small coolant leak from the passenger side valve cover, at the lower rear part of the valve cover, then the coolant leaves a small trail going down the stock UP to the stock header.

    My questions are...

    1. Can I still drive it, if I monitor the leak, add coolant as needed, and don't drive hard. The leak is very small.

    2. Is there an easy way to replace the valve cover gasket, without pulling the engine, or would it be counterproductive.

    I told myself, if I ever had to pull the engine for any reason, I would just stick a new built EJ25 in there with P&P EJ20 heads. But I have too many projects going on to do this right now.

    Let me know what you think.

    Thanks!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User BlueHeavenWRX's Avatar
    Join Date
    Oct 2005
    Location
    Philly, Schwenksville
    Posts
    81
    any advice on this???

  4. #3
    Registered User JRB1987's Avatar
    Join Date
    Aug 2008
    Posts
    73
    I would pressure test the cooling system to find the real leak.

    Replacing your valve cover gasket would not correct any coolant leak issue as there is only engine oil inside your valve covers

  5. #4
    The Default One SeattleJeremy's Avatar
    Join Date
    Jul 2004
    Location
    Seattle, WA
    Posts
    4,488
    JRB1987's right, the valve covers should only contain oil.

    Have you checked to see if antifreeze has entered the oil (IE changed your oil)?

    If it's coming from the head area, then it's more likely to be the head gasket leaking.

    Sorry

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •