2007 WRX TR Lemon?
+ Reply to Thread
Results 1 to 2 of 2

This is a discussion on 2007 WRX TR Lemon? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Ok...I'm starting this thread because I'm extremely annoyed at this point. I bought my 07 back at the end of ...

  1. #1
    Registered User bellhammer's Avatar
    Join Date
    May 2009
    Location
    Aurora, CO
    Posts
    56

    2007 WRX TR Lemon?

    Ok...I'm starting this thread because I'm extremely annoyed at this point. I bought my 07 back at the end of April of this year. So I've only had it for 7 months.

    I've already had to take it back into the dealership 5 times. And I'm looking at a 6th time now.

    The first time was fine because it was a used car and they replaced some parts on it so it was finishing up that work and finishing cleaning out the inside and whatnot.

    2nd time was at the beginning of July and they replaced the pressure plates, discs and throw out bearing

    3rd time was at the end of July. Replaced the exhaust shield because it had come loose and rattled against the drivetrain.

    4th time was beginning of September because it got broken into and almost stolen. (yea I know it should have been in a garage, but you think southlands, aurora should be ok outside...anyways problem fixed, i have an attached garage now)

    5th time was at the end of November...replaced the throw out bearing.

    Now I just got my car back from this last endeavor last weds. Pulled back into my garage after running an errand on Fri and found a 2 ft by 1/2 ft puddle of oil on the ground. It has a very distinctive stink of Axle/gear oil. And the release spring for the clutch is squeaking everytime I push in the clutch.

    My frustration is I don't ride her hard. I've only had 2 hard starts and I shift early 90 % of the time driving.

    I'm taking her back in on Tues to have the leak looked at and I've now got the number for Suba and I was going to setup an appointment for them to do one of those 150 or 170 point inspections.

    I checked the previous log for the veh from the dealership and it says that one of those were done in mid-April.

    I'm just getting frustrated with the whole deal because it feels like my car is always breaking down or having some kind of problem.

    If you were in my shoes what would you do or recommend me to do at this point?
    Id rather drive a fast car slow than a slow car fast - Micah

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Dec 2009
    Posts
    9
    hmm it sounds like you should of got an audi...

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •