Need help with p2096 code
+ Reply to Thread
Results 1 to 6 of 6

This is a discussion on Need help with p2096 code within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I'm not sure if this is the right place to post cel questions. I have an 09 wrx with tsudo ...

  1. #1
    Registered User supranai's Avatar
    Join Date
    Oct 2009
    Location
    Michigan
    Posts
    23

    Need help with p2096 code

    I'm not sure if this is the right place to post cel questions. I have an 09 wrx with tsudo cat-delete downpipe mated to a perrin cbe. I'm also running cobb access port 91/92 octane stage 2 map. The downpipe came with a cel-fix. The stock o2 sensor is in place, but every couple of days the check engine, traction control and cruise control lights come on. Check engine and traction control lights stay on but cruise control light blinks. I would reset the ecu and the same problem would show up again in about two days of driving. The code reads: post catalyst fuel trim system too lean bank 1.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Oct 2009
    Posts
    2
    I just bought a certified 08 with 12k and the dealer gave me the catless downpipe the previous owner had installed (but they removed for inspection). So, I now have the stock catted pipe on. I recently got the exact same problem you did. CEL and Traction Control off lights are on, and the cruise light blinks. I can't manually turn on traction control or cruise. Any luck solving your problem yet? My car is going in tomorrow morning to have the dealer check it out, so I'll post what they say.

  4. #3
    Registered User 97_04's Avatar
    Join Date
    Feb 2006
    Posts
    218
    I'm not a pro, especially on the 09's but have you checked the plugs/coils/o2 sensor? I know you said it came with a fix even though the o2 sensor is in place. Being so new and the fact that you have an AP should keep it from tripping any codes but you should check the obvious/physicals before going in deeper.

  5. #4
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Quote Originally Posted by DammitMike View Post
    I just bought a certified 08 with 12k and the dealer gave me the catless downpipe the previous owner had installed (but they removed for inspection). So, I now have the stock catted pipe on. I recently got the exact same problem you did. CEL and Traction Control off lights are on, and the cruise light blinks. I can't manually turn on traction control or cruise. Any luck solving your problem yet? My car is going in tomorrow morning to have the dealer check it out, so I'll post what they say.
    When the CEL illuminates the ECU disables the traction control and the cruise control hense those two lights coming on...

  6. #5
    Registered User
    Join Date
    Oct 2009
    Posts
    2
    Quote Originally Posted by EvoEatr View Post
    When the CEL illuminates the ECU disables the traction control and the cruise control hense those two lights coming on...
    Yeah I found that out this morning at the dealer. Sorry, I'm completely new to Subarus. Mine threw a p0420 for a problem with a reading from the cat.

  7. #6
    Registered User supranai's Avatar
    Join Date
    Oct 2009
    Location
    Michigan
    Posts
    23
    I was told by some locals that my car just needed to be tuned to run catless...planning on doing just that sometime this winter. Hope tunining it will get the bug out.
    09 Satin White WRX
    89 Pearl White Supra Turbo
    Stink-Eye-Mob #609

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •