'03 wrx
Results 1 to 5 of 5

This is a discussion on '03 wrx within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; so i just got an '03 wrx from the auction about a month ago. Didnt look like a bad hit, ...

  1. #1
    Registered User
    Join Date
    Nov 2009
    Location
    spokane, wa
    Posts
    7

    Exclamation '03 wrx

    so i just got an '03 wrx from the auction about a month ago. Didnt look like a bad hit, brought it home, and turns out theres 0 compression in the engine.none. gonna take the heads off soon nd find out if all the valves r bad and also maybe get new pistons.any recommendations on wat i should do? get a another used EJ20 or slowly rebuild the internals in this one?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    That's up to you. You have an opportunity to build the hell out of it if you have the funds and time. Or, if you're more interested in just driving it and not doing too much to it, I'd just go with a new to you longblock.
    Cody
    Hawk-Eye Alliance #727 N.E.R.D #255.255.255.0

    Your nighttime volunteer of near-useless information.
    Good news, everyone!

  4. #3
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    hmmm..seems extremely unlikely to me that their is absolutely no compression in any cylinders..Are you sure the compression gauge is working properly?

  5. #4
    Registered User
    Join Date
    Nov 2009
    Location
    spokane, wa
    Posts
    7

    no compression

    Quote Originally Posted by EvoEatr View Post
    hmmm..seems extremely unlikely to me that their is absolutely no compression in any cylinders..Are you sure the compression gauge is working properly?
    yeah i double checked the compression then ended up taking the heads off and every single one of the valves are bent.i took the heads to a local shop and theyre doing a full valve job for $370 (including new valves).

  6. #5
    Registered User Sarra's Avatar
    Join Date
    Aug 2008
    Location
    Dreadford, OR
    Posts
    218
    Quote Originally Posted by EvoEatr View Post
    hmmm..seems extremely unlikely to me that their is absolutely no compression in any cylinders..Are you sure the compression gauge is working properly?
    I've run into that before! Used gauge kit #1, and got 50PSI on all 6 cylinders (on a toyota V6). I switched to a different gauge, same thing. Replaced the hose, and voila! 158, 158, 157, 161, 120, 160! Bad schrader valve...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •