Am I screwed? - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 19 of 19

This is a discussion on Am I screwed? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Yea the it fixed all of my overheating issues. but my oil light still comes on randomly for like one ...

  1. #16
    Registered User
    Join Date
    May 2009
    Posts
    33
    Yea the it fixed all of my overheating issues. but my oil light still comes on randomly for like one minutes then goes off randomly. but oil level is fine so i dont know whats the deal with that is.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    UnBanned Sinister's Avatar
    Join Date
    Nov 2006
    Location
    Denver Metro Area
    Posts
    17,628
    I Support ClubWRX
    Quote Originally Posted by johnbmackin View Post
    Yea the it fixed all of my overheating issues. but my oil light still comes on randomly for like one minutes then goes off randomly. but oil level is fine so i dont know whats the deal with that is.
    do you have any leaks? do you have any water in the oil when it drains?
    Kevin
    Moderator
    Sinister's Blowoff Valve FAQ
    WRX Gas Mileage FAQ
    Sinister's Progress Thread - 430whp 429wtq - Sold
    Firearms Enthusiasts Thread

    The Sheriff's Star at the bottom left corner rates a user's reputation.
    If you found a user's post to be helpful or quite the opposite, please make it known to them by clicking the Star!

  4. #18
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,090
    I Support ClubWRX
    Quote Originally Posted by johnbmackin View Post
    Yea the it fixed all of my overheating issues. but my oil light still comes on randomly for like one minutes then goes off randomly. but oil level is fine so i dont know whats the deal with that is.
    Do you have an oil pressure gauge? If not clean the connection for the oil pressure sender or even replace the sensor it self.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  5. #19
    Registered User BrandonPaquette's Avatar
    Join Date
    Dec 2009
    Location
    Sudbury, Canada
    Posts
    93
    i just found the hole in was in the plastic on the top of the rapd but some time about 5% of the time when i start my car the oil ligth comes on for 10 _ 15 min

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •