NEED HELP!!!! Clanking at low rpm's and mph's
Results 1 to 6 of 6

This is a discussion on NEED HELP!!!! Clanking at low rpm's and mph's within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; There is a clank clank............clank......clank clank clank.......underneath the rear of my 02 wrx when im going fairly slow. Sounds like ...

  1. #1
    Registered User
    Join Date
    Oct 2009
    Location
    Palos Park, IL
    Posts
    4

    NEED HELP!!!! Clanking at low rpm's and mph's

    There is a clank clank............clank......clank clank clank.......underneath the rear of my 02 wrx when im going fairly slow. Sounds like something in the suspension???????? Any suggestions of what it might be or anything else don't hesitate to add!!! thanks.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    Is it rhythmic like does it increase in repetition as you increase in speed? Does it only do it when your moving? How many miles are on the vehicle? What model vehicle? Does it do it all the time? Even going around turns and such? Are you 100% sure its coming from the rear? Any mods done to the vehicle?

  4. #3
    Registered User
    Join Date
    Oct 2009
    Location
    Palos Park, IL
    Posts
    4
    It's a 2002 WRX bugeye with 85xxx miles on it and no suspension or engine upgrades as far as I can tell. The clanking is rhythmic, does it all the time and only when i'm moving. It does it on turns too yes and i'm almost positive its coming from either the bottom rear or middle.

  5. #4
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    I would hop under the car and do a thorough visual inspection and see if anything looks out of place...Have you had any recent work done on the vehicle? This is a shot from the hip..I'm thinking maybe a heat shield got pushed up somehow and is rubbing on your drive shaft..look on the drive shaft for a ground away portion..I've seen it many times before..something simple to check...also check for other loose heat shields...

  6. #5
    Registered User
    Join Date
    Oct 2009
    Location
    Palos Park, IL
    Posts
    4
    Alright i'll start checking thanks alot.

  7. #6
    Registered User EvoEatr's Avatar
    Join Date
    Aug 2008
    Location
    Kennett Square, Pennsylvania
    Posts
    1,839
    no prob. man..Let me know if you find anything...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •