Knock knock! whos there? my engin :(
Results 1 to 3 of 3

This is a discussion on Knock knock! whos there? my engin :( within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; so i was driving my 02 wrx back home from collage and i was doing 75 with the cruse control ...

  1. #1
    Registered User simplyyestb's Avatar
    Join Date
    Mar 2009
    Location
    oklahoma
    Posts
    26

    Knock knock! whos there? my engin :(

    so i was driving my 02 wrx back home from collage
    and i was doing 75 with the cruse control all of the sudden my check engine light starts flashing and my car starts hesitating so i coast in
    neutral to the next exit of the turnpike

    I add some oil just in case ( yes i checked it first it was closer to the
    first dot but not at it) and called Subaru and some car friends and while talking to one of my friends i decided to start the car back up and it
    started knocking LOUD everyone told me not to drive so i had it towed the rest of the way home.

    what the hell do i do now?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,083
    I Support ClubWRX
    Honestly it sounds like you don't have alot of auto mechanic background. Trying to explain every single diagnostic procedure to do is going to be like pulling teeth,especially if you don't even have the proper tools/equipment. That being said sounds like you have a rod knock. Probably spun a bearing. Not sure how good you are at keeping up with the proper maintenance and using "quality" oil and filters. You can try doing a compression check and draining the oil to see if you find metal shaving or a metallic "sheen". Maybe cut the filter open. Best bet is take it to a qualified Subie mechanic.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  4. #3
    Registered User vttk_mig69's Avatar
    Join Date
    Jan 2008
    Location
    Sheboygan, WI
    Posts
    527
    thats how it started with mine, looks like your gonna need a new engine. sry dude.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •