Do you get crazy boost with your cruse?
Results 1 to 5 of 5

This is a discussion on Do you get crazy boost with your cruse? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I just noticed, when i accelerate using my cruise i get mad crazyy booost!! Is that normal?...

  1. #1
    Registered User jakkal256's Avatar
    Join Date
    Feb 2009
    Location
    Orange County, CA
    Posts
    100

    Do you get crazy boost with your cruse?

    I just noticed, when i accelerate using my cruise i get mad crazyy booost!! Is that normal?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    What exactly do you define as crazy boost? Like actual psi. If it's within spec of stock or whatever your tune is, then it's normal. Outside of those parameters, not normal, not okay.

  4. #3
    Registered User jakkal256's Avatar
    Join Date
    Feb 2009
    Location
    Orange County, CA
    Posts
    100
    My 02 is 100% stock and my Lamco boost goes up to 0.05 boost prettty easily by using my cruise acceleration and I can hear the turbo spool up loud at that point

  5. #4
    Good news, everyone! xxxxxxxAnub1s's Avatar
    Join Date
    Jan 2005
    Location
    Eh, whaaaaa?
    Posts
    3,855
    I Support ClubWRX
    Well, .05 mPa is only ~7 psi, that's really not that much, and I would hope that your WRX is boosting better than that when at wide open throttle and appropriate RPM.

    If you're cruising around in 5th gear, you have a certain constant load on the engine which keeps the turbo partially spooled, not fully, but it explains why you are able to boost quicker than normal.

  6. #5
    Admiral Ackbar the 1st mycologist's Avatar
    Join Date
    Oct 2005
    Location
    Late Devonian
    Posts
    13,039
    I Support ClubWRX
    Yup, if your gauge is accurate your boost is really low. Stock boost should hit 13.5 PSI at sea level. It sounds like you might be running on wastegate spring pressure only.
    "From a little spark may burst a mighty flame." - Dante
    "The stitch is lost unless the thread is knotted." - Italian proverb

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •