Sputter under load
Results 1 to 3 of 3

This is a discussion on Sputter under load within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; This does not happen every time but sometimes when I pull hard it kind of stutters on the higher end ...

  1. #1
    Boost > NA itWRXjustfine's Avatar
    Join Date
    Aug 2009
    Location
    Fort Riley
    Posts
    809

    Sputter under load

    This does not happen every time but sometimes when I pull hard it kind of stutters on the higher end of the power band. I am hitting target boost but every now and again it will hit a little speed bump between 5500-6500rpm. It usually comes with a CEL as well. One time it was a cylinder 3 misfire, and lately it has been an 0442/EVAP small emissions leak. Changed the plugs and after the ECU reset it was running like a champ. I am thinking about checking resistance on the coilpacks and making a grounding kit. Anyone have any ideas?
    2004 Impreza Outback Sport - Sold
    2004 WRB WRX - Sold
    2006 SGM WRX - 400AWHP - Mods

    My 2006 Build

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Dim3s's Avatar
    Join Date
    Aug 2008
    Location
    Waukesha, Wisconsin
    Posts
    35
    I was having almost the EXACT same problems awhile back. Mine was around 5-6k ish

    My solution was that I needed to either A go with a new stock tumbler (it fried its electronical part and would sputter like you have) or go with a tumbler delete.

    More than likely sounds like it could either be that or a bad tune.

    Wish I could help more

    Edit: Here is my post from awhile back

    04 Subaru WRX STI Problems
    Last edited by Dim3s; 10-15-2009 at 12:44 AM.

  4. #3
    Boost > NA itWRXjustfine's Avatar
    Join Date
    Aug 2009
    Location
    Fort Riley
    Posts
    809
    Are there any kind of diagnosing steps I can take to see if my TGV's are bad? I am not throwing any TGV related CEL's
    2004 Impreza Outback Sport - Sold
    2004 WRB WRX - Sold
    2006 SGM WRX - 400AWHP - Mods

    My 2006 Build

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •